Eror when merging LVM snapshot

Hervé Werner hwerner at
Thu May 3 16:06:32 UTC 2012


I wanted to get some help about LVM2 snapshots, but I'm not sure where
to ask.

I'm using LVM2 with KVM instances, it works great. I then wanted to play
a little bit with the LVM snapshot merging facility, as long as the VM
is powered off it works perfectly, but when I tried with a powered on VM
I ran into troubles. The merging did not start and is now stuck :

lvdisplay :

          --- Logical volume ---
          LV Name                /dev/ScoreMD_VG01/LV_VM_SQUEEZE
          VG Name                ScoreMD_VG01
          LV UUID                9v7Jcm-vkcq-2tiq-1uFP-yDsU-zLib-JfivEM
          LV Write Access        read/write
          LV snapshot status     source of
                                 /dev/ScoreMD_VG01/SQUEEZE_SNAP [active]
          LV Status              available
          # open                 0
          LV Size                25,00 GiB
          Current LE             6400
          Segments               1
          Allocation             inherit
          Read ahead sectors     auto
          - currently set to     256
          Block device           254:6

/dev/ScoreMD_VG01/LV_VM_SQUEEZE hosts my VM
disk, /dev/ScoreMD_VG01/SQUEEZE_SNAP is the snapshot.

dmsetup status :

        ScoreMD_VG01-SQUEEZE_SNAP: 0 52428800 error 
        ScoreMD_VG01-LV_VM_SQUEEZE: 0 52428800 snapshot-merge Invalid
        ScoreMD_VG01-LV_VM_SQUEEZE-real: 0 52428800 linear 

I would like to delete the snapshot and recover the original volume.

I will be very happy if someone could give me some hints or redirect me
to the right place for asking for help.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the pkg-lvm-maintainers mailing list