Bug#795088: multipath-tools: systemd script vs sysv init script

Ritesh Raj Sarraf rrs at debian.org
Mon Aug 10 13:30:30 UTC 2015

Source: multipath-tools
Version: 0.5.0+git0.770e6d0d-1
Severity: normal

In the specified version, systemd support has been enabled. The upstream
provided multipathd.service and .socket file are shipped.

History for multipath-tools in Debian is that the init script shipped,
is named multipath-tools, where as the upstream shipped .service file is
multipathd.service, something that I'll prefer to stick to because
essentially the service is against the daemon only.

systemd provides an Alias= mechanism for situations like these, where
in, if you have an init script, to which you'd like to map your .service
file, you could add the alias.

But for Debian, this is still not clear and concluded. The issue is
being worked on in Debian Bug #719695.

Hence, this bug will be marked as a blocked-by #719695

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (101, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.1.4+ (SMP w/4 CPU cores)
Locale: LANG=en_IN.utf8, LC_CTYPE=en_IN.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

More information about the pkg-lvm-maintainers mailing list