<div dir="ltr">I am not walking away. The failure is 2 folds. If you got hit by -6, on your machine the (broken) maintainer script gets installed, which you'll have to manually remove.<div>That's something I do not want to handle in the package. Otherwise, the fix to not break the maintainer script is done.</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Mar 15, 2016 at 10:40 PM, Sven Hartge <span dir="ltr"><<a href="mailto:sven@svenhartge.de" target="_blank">sven@svenhartge.de</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On Tue, 15 Mar 2016 22:28:49 +0530 Ritesh Raj Sarraf <<a href="mailto:rrs@debian.org">rrs@debian.org</a>> wrote:<br>
<br>
> If you upgrade from -5 to -7, you shouldn't be hitting this problem. I<br>
> thought about handling the breakage, but that would touch files outside<br>
</span>> , which I'm not keen on.Â<br>
<span class="">><br>
> And Unstable is supposed to have breakages.<br>
<br>
</span>Sorry, but I find this unacceptable. Sure, Unstable can have breakages,<br>
but is not supposed to have one. You cannot just ignore one upgrade path<br>
because it is inconvenient for you.<br>
<br>
The -6 package has been release to mirrors and has been installed on<br>
systems, so you have to provide a clean upgrade path to the next package<br>
and not just walk away saying "upgrade from -6 to -7 are not supported"<br>
and leave the user to manually put the package into a working state again.<br>
<br>
Grüße,<br>
Sven.<br>
<br>
</blockquote></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature">Ritesh Raj Sarraf<br>RESEARCHUT - <a href="http://www.researchut.com" target="_blank">http://www.researchut.com</a><br>"Necessity is the mother of invention."</div>
</div>