[Pkg-mc-devel] Bug#661467: Bug#661467: mc: zip file browsing broken

Christian Ohm chr.ohm at gmx.net
Mon Feb 27 14:58:46 UTC 2012

On Tuesday, 28 February 2012 at  0:50, Dmitry Smirnov wrote:
> Strangely enough it works for me.
> I believe for ZIP-browsing functionality mc relies on 'unzip' package which 
> provides '/usr/bin/unzip' executable.
> However when I remove '/usr/bin/unzip' mc gives an error message.
> Would you be able to provide a sample archive for evaluation please?

http://developer.wz2100.net/raw-attachment/ticket/3202/savegames.zip for
example, but no other zip I tried worked. unzip can extract the files,
and F3 shows the content as well (and it worked before the update)

> Another thing worth checking is the integrity of 'unzip' package if you have 
> it installed. You can do it by installing 'debsums' package and then running a 
> 'debsums unzip' command.

debsums says OK for everything. I tried purging and reinstalling mc, but
that also didn't help. Comparing /usr/lib/mc/extfs.d/uzip with that from
the old version gave a difference, if I set my $op_has_zipinfo = 1; in
the current file instead of 0 which it is now, things work again.

Best regards,
Christian Ohm

More information about the Pkg-mc-devel mailing list