<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman,new york,times,serif;font-size:12pt"><br><div> </div><div style="color: rgb(0, 0, 0);">Brett Senior.</div><div><br></div><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><font face="Tahoma" size="2">----- Forwarded Message ----<br><b><span style="font-weight: bold;">From:</span></b> Brett Senior <brett_senior@yahoo.com.au><br><b><span style="font-weight: bold;">To:</span></b> Jo Shields <directhex@apebox.org><br><b><span style="font-weight: bold;">Sent:</span></b> Thursday, 6 November, 2008 1:05:23 PM<br><b><span style="font-weight: bold;">Subject:</span></b> Re: [Pkg-mono-devel] Problem performing an 'aptitude full-upgrade'<br></font><br><div style="font-family: times new roman,new york,times,serif;
font-size: 12pt;">Jo,<br><br> Yes I am running the AMD64 version of Debian. If 2.0 will not migrate to testing, is this permanently or for the moment. If for the moment, then do you have any idea when ? Given that I am running AMD64, why did aptitude download i386 packages ?<br><div> </div><div style="color: rgb(0, 0, 0);">Brett Senior.</div><div><br></div><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style="font-family: arial,helvetica,sans-serif; font-size: 10pt;"><font face="Tahoma" size="2"><hr size="1"><b><span style="font-weight: bold;">From:</span></b> Jo Shields <directhex@apebox.org><br><b><span style="font-weight: bold;">To:</span></b> Brett Senior <brett_senior@yahoo.com.au><br><b><span style="font-weight: bold;">Cc:</span></b> Debian Mono Project <pkg-mono-devel@lists.alioth.debian.org><br><b><span style="font-weight:
bold;">Sent:</span></b> Wednesday, 5 November, 2008 7:10:09 PM<br><b><span style="font-weight: bold;">Subject:</span></b> Re: [Pkg-mono-devel] Problem performing an 'aptitude full-upgrade'<br></font><br>On Tue, 2008-11-04 at 20:08 -0800, Brett Senior wrote:<br>> When I performed an 'aptitude update' today, it advised me that there<br>> were a number of updates to install. When I used 'aptitude<br>> safe-upgrade' it installed some mono products, version 2.01, but had<br>> problems with installing them all. So I did an 'aptitude<br>> full-upgrade' with the following results (I have debian.meebey.net in<br>> my /etc/apt/sources.list file) -<br>> <br>> <br>> Senior:/home/brett# aptitude full-upgrade <br>> Reading package lists... Done<br>> Building dependency tree <br>>
Reading state information... Done<br>> Reading extended state information <br>> Initializing package states... Done<br>> Reading task descriptions... Done <br>> The following packages are BROKEN:<br>> libmono-corlib1.0-cil libmono-corlib2.0-cil libmono-corlib2.1-cil <br>> libmono-posix1.0-cil libmono-posix2.0-cil libmono-system-web1.0-cil <br>> libmono-system-web2.0-cil libmono-system1.0-cil<br>> libmono-system2.0-cil <br>> libmono-system2.1-cil mono-2.0-devel mono-runtime mono-smcs <br>> The following packages will be upgraded:<br>> libmono-winforms2.0-cil libmono1.0-cil libmono2.0-cil mono-gac <br>> 14 packages upgraded, 2 newly installed, 0 to remove and 0 not<br>> upgraded.<br>> Need to get 9191kB of archives. After unpacking 1458kB will be used.<br>> The following packages have unmet dependencies:<br>> libmono-system2.0-cil: Depends:
libmono0 (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> libmono-corlib2.0-cil: Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> libmono-system-web1.0-cil: Depends: mono-jit (>= 2.0) but 1.9.1<br>> +dfsg-4 is installed.<br>> libmono-posix2.0-cil: Depends: libmono0 (>= 2.0) but 1.9.1+dfsg-4 is<br>> installed.<br>> mono-runtime: Depends: mono-gac (= 1.9.1+dfsg-4) but 2.0-1~pre3 is<br>> to be installed.<br>> libmono-system2.1-cil: Depends: libmono0 (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> mono-2.0-devel:
Depends: libmono-dev (= 2.0-1~pre3) but 1.9.1+dfsg-4<br>> is installed.<br>> libmono-corlib2.1-cil: Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> libmono-system1.0-cil: Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> mono-smcs: Depends: mono-runtime (>= 2.0) but 1.9.1+dfsg-4 is<br>> installed.<br>> libmono-corlib1.0-cil: Depends: mono-jit (>= 2.0) but 1.9.1+dfsg-4<br>> is installed.<br>> libmono-system-web2.0-cil: Depends: mono-jit (>= 2.0) but 1.9.1<br>> +dfsg-4 is installed.<br>> libmono-posix1.0-cil: Depends: libmono0 (>= 2.0) but 1.9.1+dfsg-4 is<br>> installed.<br>> The following actions will resolve these dependencies:<br>> <br>> Remove the following packages:<br>> mono-smcs<br>> <br>> Keep the following packages at their current version:<br>> libmono-corlib1.0-cil [1.9.1+dfsg-4 (testing,
now)]<br>> libmono-corlib2.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-corlib2.1-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-posix1.0-cil [Not Installed]<br>> libmono-posix2.0-cil [Not Installed]<br>> libmono-system-web1.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-system-web2.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-system1.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-system2.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-system2.1-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono-winforms2.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono1.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> libmono2.0-cil [1.9.1+dfsg-4 (testing, now)]<br>> mono-2.0-devel [1.9.1+dfsg-4 (testing, now)]<br>> mono-gac [1.9.1+dfsg-4 (testing, now)]<br><br>I smell AMD64<br><br>Meebey's repository only has i386 packages for Mono 2<br><br>And Testing will only get 1.9.1, 2.0 will not migrate<br><br></div></div></div><br>
<hr size="1"> Search 1000's of available singles in your area at the new Yahoo!7 Dating.
<a rel="nofollow" target="_blank" href="http://au.rd.yahoo.com/dating/mail/tagline1/*http://au.dating.yahoo.com/?cid=53151&pid=1011">Get Started</a>.</div></div></div><br>
<hr size=1> Search 1000's of available singles in your area at the new Yahoo!7 Dating.
<a href="http://au.rd.yahoo.com/dating/mail/tagline1/*http://au.dating.yahoo.com/?cid=53151&pid=1011">Get Started</a>.</body></html>