Bug#643046: iceweasel 6.0.2-1 crashes on load when gecko-mediaplayer is installed

E Taylor hagfish at hagfish.name
Mon Sep 26 19:41:41 UTC 2011

Package: iceweasel
Version: 6.0.2-1

I run testing/wheezy and upgraded to iceweasel 6.0.2 this weekend, 
closing my running copy of iceweasel first.  When I tried to load it 
again, it got as far as loading all the windows and showing all of the 
tabs, but before the pages had finished loading it crashed.  Upon 
reopening iceweasel, I was presented with the "Restore session" page and 
could browse normally by opening new tabs, but when I told it to restore 
my existing session, it crashed again at the same point.  I tried 
loading the session with images and JavaScript turned off, and in safe 
mode, but nothing worked.

Eventually I tried loading iceweasel from the command line and found 
this message printed there:

/usr/lib/iceweasel/firefox-bin: symbol lookup error: 
/usr/lib/mozilla/plugins/gecko-mediaplayer-dvx.so: undefined symbol: 

By doing a web search for this, I found that users of another distro had 
encountered the same problem:


The suggested work around was to uninstall the package gecko-mediaplayer 
and I did this, which fixed the problem.  (When I went to re-enable some 
of my settings, though, I experienced another crash which turned out to 
be Debian bug 626076 but the work around in comment #5 worked:


and now I am using the browser normally).

I'm guessing that the iceweasel package should at least be marked as 
conflicting with the gecko-mediaplayer package, unless this can be 
resolved some other way.

Best regards,
Edwin Taylor

More information about the pkg-mozilla-maintainers mailing list