<html><head/><body><html><head></head><body>We can always locate them using dpkg if we are unsure of their names, so a prefix or other small adjustment should be fairly innocuous.<br>
-- <br>
Sent from my mobile device.<br><br><div class="gmail_quote">Daniel Kahn Gillmor <dkg@fifthhorseman.net> wrote:<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
<pre style="white-space: pre-wrap; word-wrap:break-word; font-family: monospace; margin-top: 0px">On 03/22/2013 01:51 AM, Mike Hommey wrote:<br /><br /><blockquote class="gmail_quote" style="margin: 0pt 0pt 1ex 0.8ex; border-left: 1px solid #729fcf; padding-left: 1ex;">I'm not particularly happy with binaries with pretty generic names<br />("addbuiltin" is a good example of such) ending up in /usr/bin...<br />But you can try to convince me otherwise. Or move them in some other<br />directory.</blockquote><br />hm, i think the following new binaries should be unobjectionable in<br />/usr/bin :<br /><br />p7content<br />p7env<br />p7sign<br />p7verify<br />symkeyutil<br />ocspclnt<br />chktest<br />derdump<br />rsaperf<br />vfychain<br />vfyserv<br /><br /><br />These two TLS client utilities and two TLS server utilities have<br />somewhat generic names, but i think are useful enough to ship in<br />/usr/bin despite the genericness (they can be used along with gnutls-cli<br />and
gnutls-serv and "openssl s_client" and "openssl s_server" to do<br />interop testing for new TLS clients and servers, for example):<br /><br />strsclient<br />tstclnt<br />httpserv<br />selfserv<br /><br />The following three are the most dubious in terms of names:<br /><br />addbuiltin<br />pp<br />dbtest<br /><br />i'd be fine shipping the last category and optionally the client/server<br />utilities with an nss- prefix if you think that would be more<br />acceptable. I'd rather not move them entirely out of the $PATH if<br />possible. and i'd prefer to not rename existing tools that we have<br />already been shipping in libnss3-tools, of course.<br /><br />Would you like me to prepare an alternate patch that does that renaming<br />on one or both groups?<br /><br /> --dkg<br /><br /></pre></blockquote></div></body></html></body></html>