[SCM] libav/experimental: Rename avfilter_create to avfilter_open and remove the wrapper function avfilter_create_by_name.

siretart at users.alioth.debian.org siretart at users.alioth.debian.org
Sun Jun 30 16:14:30 UTC 2013


The following commit has been merged in the experimental branch:
commit 44b73497d31ffad6e0c89927006edeb58654fac3
Author: Vitor Sessak <vitor1001 at gmail.com>
Date:   Fri Feb 15 21:38:25 2008 +0000

    Rename avfilter_create to avfilter_open and remove the wrapper function
    avfilter_create_by_name.
    
    Commited in SoC by Bobby Bingham on 2007-08-17 23:39:55
    
    Originally committed as revision 12014 to svn://svn.ffmpeg.org/ffmpeg/trunk

diff --git a/libavfilter/avfilter.c b/libavfilter/avfilter.c
index 50d15bf..08007dc 100644
--- a/libavfilter/avfilter.c
+++ b/libavfilter/avfilter.c
@@ -304,7 +304,7 @@ static const char *filter_name(void *p)
     return filter->filter->name;
 }
 
-AVFilterContext *avfilter_create(AVFilter *filter, char *inst_name)
+AVFilterContext *avfilter_open(AVFilter *filter, char *inst_name)
 {
     AVFilterContext *ret = av_malloc(sizeof(AVFilterContext));
 
@@ -355,14 +355,6 @@ void avfilter_destroy(AVFilterContext *filter)
     av_free(filter);
 }
 
-AVFilterContext *avfilter_create_by_name(char *name, char *inst_name)
-{
-    AVFilter *filt;
-
-    if(!(filt = avfilter_get_by_name(name))) return NULL;
-    return avfilter_create(filt, inst_name);
-}
-
 int avfilter_init_filter(AVFilterContext *filter, const char *args, void *opaque)
 {
     int ret;

-- 
Libav/FFmpeg packaging



More information about the pkg-multimedia-commits mailing list