[SCM] calf audio plugins packaging annotated tag, 0.0.16, created. 0.0.16

js at users.alioth.debian.org js at users.alioth.debian.org
Tue May 7 15:41:28 UTC 2013


The annotated tag, 0.0.16 has been created
        at  cc3dc4ff24bd71f74f8604df5c6cb90ce0c555f1 (tag)
   tagging  f44fc26f6ff65b9829ea38117fdde0006fad5e58 (commit)
  replaces  0.0.15
 tagged by  Krzysztof Foltman
        on  Wed Oct 29 20:00:14 2008 +0000

- Shortlog ------------------------------------------------------------
Version 0.0.16

Krzysztof Foltman (13):
      + SubSyn: added a non-working crappy saw resynthesizer plugin (just an experiment)
      + Multi Chorus: new effect added (incomplete)
      + MultiChorus: new effect added (incomplete)
      + MultiChorus: implement stereo phase (the plugin is still very unpolished though!)
      Merge branch 'master' of ssh://repo.or.cz/srv/git/calf
      + MultiChorus: change multilfo interface to output value instead of phase (+update multichorus), make scale 1/sqrt(N) instead of 1/N, move scale calculation outside the loop, remove leftover printf
      + MultiChorus: fix stereo phase
      + MultiChorus: add inter-voice phase parameter, adjust default parameter values to give more noticable effect
      + MultiChorus: ensure the effect works correctly (at least in theory) even with overhyped sample rates (a safe maximum is now 192 kHz), add useful comments
      + MultiChorus: make number of voices adjustable, make default settings even more in-your-face
      + AutoHell: update version number, add missing lv2_contexts.h to Makefile.am
      + AutoHell: Add missing calf.desktop file and .gitignore
      + ChangeLog: updated for 0.0.16

kfoltman (72):
      + Big Bull: useless parser improvements, attempt at starting some Python JACK API contraption
      + Big Bull: rewrite TTL scanner in a proper programming language ;) to improve compatibility (now depends on flex instead of python.yappy)
      + Big Bull: removed autogenerated header file, added bang line to inspect.py, added Python exception setting to scanner
      + Big Bull: fix some kindergarten type bugs
      + Big Bull: added very primitive support for connecting ports (just GUI, there is no underlying model whatsoever)
      + Big Bull: add connect/disconnect functions and some common constants to calfpytools
      + Big Bull: event handling refactoring in mainwin
      + Big Bull: refactoring - push module context menu out of the ConnectionGraph
      + Big Bull: support epp:notAutomatic, split out create_items
      + Big Bull: make the port code use separate class (ModulePort), move domain specific code from graph classes into separate parser class
      + Big Bull: add Python wrapper for jack_get_ports
      + Big Bull: fix type filter in get_ports, more tests for get_ports
      + Big Bull: add get_type() to JackPort, make a separate module out of graph editor thingy, implement lousy connection and disconnection logic, add a small JACK connection graph toy program
      + Rotary Speaker: 0/90 deg shift thingy
      + Framework: simplify adding new modules by moving module list to separate file (modulelist.h)
      + Small plugins: add 6dB lowpass, 6dB highpass and 1p1z allpass
      + Framework: new framework for small plugins (LV2 only); small plugins will not be available as LADSPA/DSSI/JACK from now on
      + Small plugins: add square and saw oscillators
      + Small plugins: add print (Control) and print (Audio) plugins, fix onepole filters, add reset to onepole constructor (just in case)
      + Small plugins: fix allpass name (preventing correct instantiation)
      + Small modules: cleanup to have plugin IDs in just one place, added two versions of Quad Power plugin (calculates x*a, x*a^2, x*a^3, x*a^4 for control or audio x, for octaves/detune/whatever)
      + Framework: separate some plugin .so specific code and data into separate .cpp file, move small plugins' code to separate .cpp file, reduce dependencies, make a simpler version of null_plugin base class for use in small plugins, use qualified names for stuff from std namespace in primitives.h instead of 'using' keyword, other minor cleanups
      + Framework: unbreak plugins, documentation and functionality enhancements ("undersampling") in inertia class
      + Small plugins: unbreak Exp Inertia, add (A) to min/max/mul/sub/neg module names
      + Small modules: new Sample&Hold and Edge Detector modules
      + Small modules: logical AND/OR/NOT control signal plugins, add custom classification instead of polluting "Utility" class, refer to lv2:portProperty properly
      + Small modules: added pulse LFO and T flip-flop (edge-triggered toggle), better port hints in edge detector
      + Big Bull: workaround for goocanvas text sizing weirdness
      + Small plugins: renamed print and print2 to include data type, added Schmitt trigger and two comparison operators - less-than and between
      + Framework: allow arbitrary TTL for ports and micronames for plugins and ports
      + Framework: microname fixes
      + Framework: another microname fix
      + Small modules: new plugin - control-rate clipper, changed default range in between plugin
      + Big Bull: added a default hinting patch for GooCanvas (makes it slightly less ugly)
      + Big Bull: automatic sizing of modules, minor visual tweaks to reduce canvas ugliness
      + Big Bull: add the ability to monitor port registrations/connections (but not client registrations, yet)
      + Big Bull: replace flat plugin menu with hierarchical one
      + Small plugins: remove duplicate name triples (found by Dave Robillard, thanks!)
      + LV2: added context extension header
      + Small modules: clean up print_em, print event buffer pointers on message_connect_port and message_run, fix incorrect plugin name
      + Small modules: fix assertion in print_em, add a (most likely broken) pass-through module (copy_em)
      + Framework: make control outputs work again (oops... hurried refactoring without enough testing is never working properly)
      + Small plugins: added priority multiplexer and control versions of minus, mul and neg plugins
      + Big Bull: make ConnDiagram style more FlowCanvas-like, add a dumb spring-based layout algorithm (used for initial layout in JackVis)
      + Big Bull: make layout algorithm a bit less horrible by adding "simulated annealing"-like randomization
      + Small modules: rename 'context' to 'contexts' in some URIs in lv2_context.h, message context related changes
      + Small modules: added control version of Minimum and Maximum, renamed audio Min and Max to Minimum and Maximum
      + Small modules: added bitwise AND, OR and XOR operations
      + Small modules: new modules - priority encoder, if-then-else and unidirectional counter
      + Small modules: renamed prio_enc_c to prio_enc8_c before anyone has chance to use it, updated its doxygen documentation, added new 8-input multiplexer plugin (it's possible to make a simple step sequencer now with only a little effort!)
      + Small modules: templatized the mux and prio_enc code to be able to add different-number-of-inputs versions more easily, added mux4 and mux16 this way
      + Small modules: added a LV2 event iterator (for lulz), modified dump plugin to use it instead of doing low-levelish data manipulation
      + Small modules: very-much-improved pair of event buffer iterators; two simple MIDI plugins - note filter and note filter 2 (splits notes into notes and non-notes); implemented "personalized" handling of LV2_Feature values in small plugins (allowing to use mixins for features - see: midi_mixin)
      + Framework: general refactoring (move LV2 helper classes to separate files, use "curiously recursive template pattern" instead of a macro for wavetable storage, do not define large/small per item macro if not used, add missing copyright/license header to lv2wrap.h)
      + Small modules: add Event Merge plugin based on the new merging event buffer iterator
      + Framework: separated midi_mixin into event_mixin and midi_mixin which is dependent on it
      + LV2: fix compile error due to lv2_event.h update in the previous check-in
      + LV2: changed lv2_event structure so that it cannot be constructed (to prevent accidental stack overwrites)
      + Small modules: added Set Channel, Key Less-than, Key Range, Channel Less-than plugins (mostly untested, might be very buggy), renamed transpose_em to transpose_m (stupid mistake)
      + Small modules: add a plugin that calculates a logical OR of its audio input, and writes the value to a control output (useful for audio rate triggers)
      + Framework: Moved URI map extension-related stuff to event_mixin where it belongs (actually, it belongs somewhere else, but this will do for now)
      + Testing: Tweaks to expected message format in Msg Read (added serial_no and data_size)
      + Framework: first foundations of a small plugin GUI framework
      + Autohell: fix JACK2-incompatible JACK check and possible problem with GTK+ headers
      + Envelope code: added Doxygen documentation
      + Envelope code: add missing #include statements
      + Monosynth: add workaround for JACK 2 note off bug (http://trac.jackaudio.org/ticket/90)
      + Phaser: fix conflicting LADSPA ID
      + SubSyn: added a non-working crappy saw resynthesizer plugin (just an experiment)
      + Multi Chorus: new effect added (incomplete)
      + MultiChorus: new effect added (incomplete)
      + MultiChorus: implement stereo phase (the plugin is still very unpolished though!)

-----------------------------------------------------------------------

-- 
calf audio plugins packaging



More information about the pkg-multimedia-commits mailing list