[SCM] libav/experimental: dv: Replace a magic number by sizeof()

siretart at users.alioth.debian.org siretart at users.alioth.debian.org
Sun Aug 10 16:03:36 UTC 2014


The following commit has been merged in the experimental branch:
commit 593d2326ef985cdffe413df629419938f7b07c4c
Author: Diego Biurrun <diego at biurrun.de>
Date:   Fri Feb 7 10:42:35 2014 +0100

    dv: Replace a magic number by sizeof()

diff --git a/libavcodec/dv.c b/libavcodec/dv.c
index 03ef695..e840f48 100644
--- a/libavcodec/dv.c
+++ b/libavcodec/dv.c
@@ -307,7 +307,7 @@ av_cold int ff_dvvideo_init(AVCodecContext *avctx)
     /* 248DCT setup */
     s->fdct[1]     = dsp.fdct248;
     s->idct_put[1] = ff_simple_idct248_put;  // FIXME: need to add it to DSP
-    memcpy(s->dv_zigzag[1], ff_dv_zigzag248_direct, 64);
+    memcpy(s->dv_zigzag[1], ff_dv_zigzag248_direct, sizeof(s->dv_zigzag[1]));
 
     s->avctx = avctx;
     avctx->chroma_sample_location = AVCHROMA_LOC_TOPLEFT;

-- 
Libav/FFmpeg packaging



More information about the pkg-multimedia-commits mailing list