[Pkg-octave-devel] Bug#458852: Bug#458852: octave3.0 crashes on arm

Thomas Weber thomas.weber.mail at gmail.com
Tue Jan 29 08:49:14 UTC 2008

Am Donnerstag, den 10.01.2008, 10:44 +0100 schrieb Soeren Sonnenburg:
> On Thu, 2008-01-10 at 10:23 +0100, Rafael Laboissiere wrote:
> > * Soeren Sonnenburg <bugreports at nn7.de> [2008-01-08 08:47]:
> > 
> > > OK, I've recompiled octave w/ -O2 -g and it dies on loading
> > > dispatch.oct. This could be enough info for upstream to fix it.
> > 
> > Thomas Weber has forwarded your message to bug-octave and John Eaton replied
> > to it [1] and gave the following suggestion:
> > 
> >    Have you tried building with -O0?  If that works but -O2 fails, then I
> >    would start to suspect an ARM-specific compiler bug since compiling
> >    with GCC and -O2 works on many other systems.
> > 
> > Could you please try it?
> Tried already, as the original debian package builds with -O0 and
> without lapack ... and there it crashed too (that was my first
> backtrace).
> I only enabled -O2 and lapack as was wondering why it is not enabled...

Speed reasons; compile time on ARM is a pain.

Okay, I give up. After spending days (mostly waiting for qemu to finish
compiling), I still don't have a clue. Mail to debian-arm went
unanswered[1], #debian-arm couldn't help either. I think it's an alloca
issue, but I lack the knowledge to decide this.

I suggest we drop ARM from the to be built architectures. Given the
nature of the bug, the fact that we had this bug for several months and
no bug report about it, I don't think we have any real users out there
on this architecture. 

Meanwhile, real testing users are told by upstream to upgrade to 3.0
(which I support, that's why there's a new release).

[1] http://lists.debian.org/debian-arm/2008/01/msg00069.html


More information about the Pkg-octave-devel mailing list