[Pkg-octave-devel] Bug#523496: Bug#523496: octave3.0-headers: tight gcc dependencies incorrect

Rafael Laboissiere rafael at debian.org
Fri Apr 10 18:11:02 UTC 2009

* Aaron M. Ucko <ucko at debian.org> [2009-04-10 13:04]:

> Package: octave3.0-headers
> Version: 1:3.0.5-1
> Severity: grave
> Justification: renders package unusable (uninstallable)
> octave3.0-headers now aims to depend on exact upstream gcc versions,
> but its approach is somewhat off, in that the dependencies are on
> metapackages that have epochs and don't depend so tightly on the
> actual compiler packages.  As such, I believe you'll need to generate
> dependencies along the following lines:
>    gcc (>= 4:4.3), gcc (<< 4:4.4), gcc-4.3 (>= 4.3.3), gcc-4.3 (<< 4.3.4)
> and likewise for g++ and gfortran.
> Could you please fix the dependencies, which currently leave the
> package uninstallable due to the epoch mismatch?

Sure, I have overseen this.  I will fix it tonight.

At any rate, I do not understand why you suggest to depend on both gcc and
gcc-4.3.  Would the following be okay?

    gcc (>= 4:4.3.3), gcc (<< 4:4.3.4)
Unfortunately we need to depend on a precise version (4.3.3 currently
because paths containing this version number is hard-coded in mkoctave.
We should discuss with upstream about this.

More information about the Pkg-octave-devel mailing list