[Pkg-octave-devel] Bug#735557: transition: octave3.8

Rafael Laboissiere rafael at laboissiere.net
Fri Jan 17 12:57:14 UTC 2014

* Thomas Weber <tweber at debian.org> [2014-01-16 16:47]:

> On Thu, Jan 16, 2014 at 02:47:31PM +0100, Sébastien Villemot wrote:
>> We should probably divide the work among us. Maybe we could use the wiki 
>> page to coordinate this? Also, if you file bugs against some packages, 
>> please mark them as blocking the transition bug.
> Agreed. I had a look at the new release of image and it requires 3.8 
> already.

I updated the Git repository for version 2.2.0 of octave-image.

I am wondering how we could force the build-dependency to octave >= 
3.8.  The octave-image pacage has currently:

    Build-Depends: debhelper (>= 9), cdbs, octave-pkg-dev (>= 1.0.0)

We could upload a new version of octave-pkg-dev, which would have:

    Depends: liboctave-dev (>= 3.8.0)

and make octave-image build-depend on that version or later.  Would this 
be appropriate?


More information about the Pkg-octave-devel mailing list