[Pkg-ofed-devel] [Fwd: Re: ofa-kernel: ib_query_gid() failed]

Guy Coates gmpc at sanger.ac.uk
Tue Oct 13 12:38:36 UTC 2009

-------- Original Message --------
Subject: Re: [Pkg-ofed-devel] ofa-kernel: ib_query_gid() failed
Date: Tue, 13 Oct 2009 14:38:44 +0200
From: Simon Kainz <simon.kainz at tugraz.at>
To: Guy Coates <gmpc at sanger.ac.uk>
CC: Mario Lang <mlang at delysid.org>
References: <87ljjg4muq.fsf at x4.delysid.org> <4AD36DA7.1020103 at sanger.ac.uk> 
<878wfg44be.fsf at x4.delysid.org> <4AD46E5E.40705 at sanger.ac.uk>

Guy Coates wrote:
> Mario Lang wrote:
>> Guy Coates <gmpc at sanger.ac.uk> writes:
>>> Also, if you add the GUIDs into /etc/default/opensm, you should avoid
>>> the ibstat call in the opensm init script altogether.
>> Yes, I know, and that is what I actually did.
>> However, ibstat failing is, as you wrote in another mail in this thread,
>> pointing to something very fundamental being broken.
> I think the next step would be to open a bug upstream;
> Please cc me on the bug, and I'll obviously supply any info needed on
> how the kernel modules are built and configured etc.
> https://bugs.openfabrics.org/
> linux-rdma at vger.kernel.org
> Sorry I cannot be of more help; not being able to reproduce the problem
> is very frustrating.
> Guy


It seems we fixed it. :-)  Here a short writeup of what we did:

We originally used 1.4.2 which led to XRC troubles and gave no valuable
error info in dmesg.  When then used 1.4.1 under 2.6.26-2-amd64 and
compiled new modules. This led to error

command 0x13 failed: fw status = 0x1

(amongst others) in dmesg.

After seeing this


we  loaded mlx4_core with msi_x=0 and there where no errors whatsoever.
  This also works now with 1.4.2.

Maybe this should be mentioned in the Howtos somewhere, to save someone
else troubles.


DI Simon Kainz
Graz, University of Technology
Department Computing
Phone: ++43 (0) 316 / 873 6885

Dr. Guy Coates,  Informatics System Group
The Wellcome Trust Sanger Institute, Hinxton, Cambridge, CB10 1HH, UK
Tel: +44 (0)1223 834244 x 6925
Fax: +44 (0)1223 496802

 The Wellcome Trust Sanger Institute is operated by Genome Research 
 Limited, a charity registered in England with number 1021457 and a 
 company registered in England with number 2742969, whose registered 
 office is 215 Euston Road, London, NW1 2BE. 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-ofed-devel/attachments/20091013/9062dc1c/attachment.pgp>

More information about the Pkg-ofed-devel mailing list