[libclc] 21/92: [Support] Rename tool_output_file to ToolOutputFile, NFC

Andreas Boll aboll-guest at moszumanska.debian.org
Mon Nov 6 15:11:56 UTC 2017


This is an automated email from the git hooks/post-receive script.

aboll-guest pushed a commit to branch master
in repository libclc.

commit df9db2adca3410df8d6b15b6d1591bb1aa10f003
Author: Reid Kleckner <rnk at google.com>
Date:   Sat Sep 23 01:03:17 2017 +0000

    [Support] Rename tool_output_file to ToolOutputFile, NFC
    
    This class isn't similar to anything from the STL, so it shouldn't use
    the STL naming conventions.
    
    git-svn-id: https://llvm.org/svn/llvm-project/libclc/trunk@314050 91177308-0d34-0410-b5e6-96231b3b80d8
---
 utils/prepare-builtins.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/utils/prepare-builtins.cpp b/utils/prepare-builtins.cpp
index 882dadd..570ed43 100644
--- a/utils/prepare-builtins.cpp
+++ b/utils/prepare-builtins.cpp
@@ -84,8 +84,8 @@ int main(int argc, char **argv) {
   }
 
   std::error_code EC;
-  std::unique_ptr<tool_output_file> Out
-  (new tool_output_file(OutputFilename, EC, sys::fs::F_None));
+  std::unique_ptr<ToolOutputFile> Out(
+      new ToolOutputFile(OutputFilename, EC, sys::fs::F_None));
   if (EC) {
     errs() << EC.message() << '\n';
     exit(1);

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-opencl/libclc.git



More information about the Pkg-opencl-commits mailing list