[libhijk-perl] annotated tag upstream/0.17 created (now 8f0c9bd)

gregor herrmann gregoa at debian.org
Sun Oct 12 16:42:18 UTC 2014


This is an automated email from the git hooks/post-receive script.

gregoa pushed a change to annotated tag upstream/0.17
in repository libhijk-perl.

        at  8f0c9bd   (tag)
   tagging  6069c0cee7a23e0f35b7fcd6c2cf940f647e6396 (commit)
 tagged by  gregor herrmann
        on  Sun Oct 12 18:27:31 2014 +0200

- Log -----------------------------------------------------------------
Upstream version 0.17

Damian Gryski (2):
      fetch: support http servers who buffer lines
      Return the HTTP protocol version, and close the connection if we're 1.0.

David Steinbrunner (2):
      typo fixes
      added cpan repository metadata

Kang-min Liu (102):
      to begin with... a trivial get() method.
      be specific about newline
      properly handle Content-Length if its there.
      new name!
      directly use Socket instead of having to load all the IO::* stacks.
      add "query_string" as a separate argument.
      split out the part that builds http message for the sake of testing it individually.
      rework a bit on reading HTTP message
      the "path" should be default to "/" -- just so we do not construct an invalid request.
      an example program using Hijk and do something similar to curl.
      Merge branch 'master' of github.com:gugod/Hijk
      a few tests for http message generation.
      prevent running live tests for non-authors.
      travis-ci config.
      some description.
      Description about Hijk::request subroutine.
      Use cpanfile to declare dependencies.
      setup Makefile.PL
      module prerequisite for travis-ci.
      try to deal with cpan auto-config.
      ditto
      ditto.
      add a test for pp_fetch.
      Let pp_fetch returns a 3rd element that is the parsed header hash.
      save us one variable.
      When Content-Length is bogus we might invoke POSIX::read() to read
      setup MANIFEST.SKIP for pure-perl dist.
      shipit
      minor pod update/fixes.
      Add `head` request arg.
      add -H and -d cli arg like curl.
      should also ignore META.json
      some extra steps to simplify the releasing process.
      rename these test files to reflect what it is testing.
      version bump.
      Merge branch 'master' of github.com:gugod/Hijk
      Also return the "head" (HTTP header as a hash).
      Merge branch 'master' of github.com:gugod/Hijk
      try testing live with elasticsearch server.
      so interestingly each item in "env" is exported individually rather then together...
      setup coverage report to coveralls.io.
      take a peek of the auto-initialized cpan config.
      describe the "head" value of the response.
      prevent invoking the global $SIG{__DIE__} when Hijk::HTTP::XS is not installed.
      done peeking the generated config.
      prepare a psgi server that takes time to do nothing.
      Implement socket read timeout.
      Plack, for testing.
      die if select(2) results an error.
      follows the XS implementation
      since we parameterized timeout for 'fetch', might as well ditch the
      live timeout testing with the local "it-takes-time" server.
      Merge branch 'master' of github.com:gugod/Hijk
      implement socket connect timeout.
      apparently POSIX can already export INPROGRESS
      bump version and noted the major change.
      Let the 'timeout' value of 'Hijk::request' be in seconds.
      timestamp
      another generic benchmark program using Dumbbench.
      dying with $!
      invalidate connection cache when seeing 'Connection: close' in the
      rename this file to indicate that it is using Dumbbench.
      various small tweaks.
      releasing 0.05.
      miss the dependency Test::Exception.
      require Net::Ping 2.41 (for older perl version)
      Ditch the 'fetch' option and rework a8bfd9b2efbba9aaa57049efd45a3e0098f1d917
      Making 0.09 release.
      instruct travis-ci to run the test twice with/without HIJK_XS
      retry.
      Merge branch 'master' of github.com:gugod/Hijk
      minor documentation tweaks
      Remove v5.14.2 requirement.
      delete previous cover_db before running prove.
      retry.
      Create README.md
      Let the response include timeout errors
      update the test to check Hijk::Error::* instead.
      return read timeout in XS version of `fetch`
      re-enable t/live-elasticsearch.t on travis-ci
      some documentation updates and editing.
      remove this self-canceling numerical operation
      Merge pull request #7 from rbastic/master
      rename Hijk::fetch to something more meaningful.
      remove the statements that requires a monotonic clock.
      disable a few tests if $ENV{http_proxy} is there.
      just wrong, plain wrong.
      revert the write timeout to be just a connect timeout, like it used to be.
      Merge branch 'non_blocking'
      summerize the change in the non_blocking branch
      check for socket errors and set $!
      put these tests that connects to google.com together
      just die on socket errors.
      prepare to release 0.13
      add live tests against a couchdb server.
      update perl versions supoorted by travis-ci.
      test faster.
      Merge branch 'master' into chunked_and_no_content_len
      minor touch to avoid autovivification
      Revert "minor touch to avoid autovivification"
      running benchmarks on chunked response.
      bump version

Robin Sheat (1):
      Import original source of Hijk 0.13

Ryan Bastic (1):
      Some minor spelling fixes and rewording

borislav nikolov (36):
      add simple XS http parser, and try to use it if possible
      read partialy until response header end
      xs: fetch(fd) -> return (status,body,headers_hashref)
      switch from recv to read to be consistent with Hijk::pp_fetch, add the parse-http-message.t from Hijk
      update pod; and use pod2text XS.pm > README
      add simple benchmark between http::tiny, lwp, hijk::pp and hijk:xs
      update MANIFEST
      update readme
      add recv timeout support; and fd_set_blocking helper function
      hijk::xs - return the same timeout message as pp_fetch
      xs: add chunked message parsing test
      hijk::xs - let http_parser_execute handle (read() == 0)
      shutdown and delete the cached connection in case of read error
      handle syswrite() returning undef
      hijk: always send timeout to $fetch->()
      tests: add test for connect with timeout 0 and read with timeout 0
      bench-elasticsearch: use the new fetch => \&Hijk::HTTP::XS::fetch to benchmark; update the results
      add test for empty connection close message without content-length; simple file fetch cmpthese
      examples/bench* switch to cmpthese and show some results from my archaic laptop
      die on forced connection close from the other end
      test: add test simulating reading 0 bytes from the stream
      xs: die on socket/poll error like pp_fetch()
      delete the cached socket in case fetch() dies
      fix broken-brain-modification
      test: xs version throws exception on fetch() now
      one more try on handling die() in fetch()
      dont hide anything within__disconnect()
      xs: use xpushs instead of pushs
      use non-blocking socket; decrease timeout after io
      use next instead of continue; .. this is what happens after to much cing
      just use POSIX(:errno_h)
      typo fixes
      add chunked encoding support; correctly handle no content len header
      dont use goto; add test for no-content-len
      add a Trailer header exception, add a big header test case
      actually read the trailer data, but ignore it (acceptable per http://tools.ietf.org/html/rfc2616#section-3.6.1)

gregor herrmann (1):
      Imported Upstream version 0.17

Ævar Arnfjörð Bjarmason (55):
      Makefile.PL: Parens for a less sucky error message
      Lower perl dependency to 5.14.2
      Document that bodies without Content-Length will be dropped
      Nuke boilerplate constant stuff that wasn't even used
      t/simple.t: don't run network tests unless NETWORK_TESTS=1
      t/simple.t: correct perl syntax
      Don't tie using the XS module to whether we can load it
      Don't tie using the XS module to whether we can load it (again)
      Hijk::HTTP::XS: Get rid of boilerplate
      Forgot to patch another autogenerated file in the last commit, just nuke it
      Remove a stray { from the SYNOPSIS
      Show a POST request in the SYNOPSIS
      Release 0.06
      Fix a test bug in 0.06 and release 0.07
      Changelog and version bump for 0.08
      Changes: Changes for 0.10 so far
      Turn the errors into a bitfield
      Remove the Hijk::HTTP::XS module
      Skip ES search unless TEST_ELASTICSEARCH
      Micro-optimize: save one op (!)
      Solve *all the things*
      Document the Hijk::Error::* constants
      Implement an on_connect callback
      Bump to 0.10
      Add documentation and a comment for the HTTP/1.0 connection closing
      Fix up this bizarro fetch initialization
      Consistency in how we pass errors around
      Change the cache_key to something more idiomatic & document it
      Solve a stupid bug in 00447c2
      Bump version to 0.11
      Merge pull request #9 from audreyt/patch-3
      Add 'use warnings' to tests that are missing it
      Add an error constant for domain resolution failures
      Bump the version to 0.12
      Merge pull request #11 from dsteinbrunner/patch-1
      Merge pull request #12 from dsteinbrunner/patch-2
      Check if we have CLOCK_MONOTONIC at compile-time
      Check if we have CLOCK_MONOTONIC at compile-time (again)
      Assigning undef to variables is redundant
      request sub: use eval idiom that doesn't require so much brainpower
      Just stick a thing that fits easily on one line on one line
      Rearrange the arguments of read_http_message()
      FFS, fix syntax error in 1c97ef1
      Fix a bad bug in the chunked encoding and disable it by default
      Bump the version to 0.15
      Just stick a thing that fits easily on one line on one line (again)
      Extend the error constants to cover read & select errors
      Copyedit the docs, mention what this library is for etc.
      Split up the start of _read_http_message()
      Add ability to return the headers as an array, resolves issue #17
      Make the read_length option configurable
      Tests: Fix duplicate my variables
      Bump the version to 0.16
      Edit the docs some more
      Bump version to 0.17

唐鳳 (1):
      Fix double negatives in POD

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-perl/packages/libhijk-perl.git



More information about the Pkg-perl-cvs-commits mailing list