[libnet-cli-interact-perl] annotated tag upstream/2.142720 created (now 48c0d36)

gregor herrmann gregoa at debian.org
Sat Oct 18 20:20:15 UTC 2014


This is an automated email from the git hooks/post-receive script.

gregoa pushed a change to annotated tag upstream/2.142720
in repository libnet-cli-interact-perl.

        at  48c0d36   (tag)
   tagging  1cbf36005f325f4b89cb370a842e90574ab01fb2 (commit)
  replaces  upstream/2.142010
 tagged by  gregor herrmann
        on  Sat Oct 18 22:15:41 2014 +0200

- Log -----------------------------------------------------------------
Upstream version 2.142720

Alexander Hartmaier (1):
      Fix Cisco prompt detection when containing [] characters

Oliver Gorwits (294):
      new branch for declarative rewrite
      initial import of working phrase parser
      add phrasebook for ios
      rename into Net::Appliance::Session
      tidy up type checks
      update dist.ini for new copyright holder
      add convenience class NAS as alias to Net::Appliance::Session
      ditch Moo for Moose, get a working IPC::Run with scalarrefs
      ditch Moo and go all out for Moose
      move namespace of Action
      move the Transport role to be under Role::
      working IPC::Run and first prompt detection from state matching
      implement macro, cmd, to_state, tested and working!!
      factor out storage of last_response
      implement ActionSet to better manage responses and preparation of send data - paves the way for sprintf in send
      send statements are passed through sprintf
      can use clone() instead of manually building new Action
      do not need carp yet
      implement basic continuation, and data marshalling
      add comments and re-use count()
      make host a param of the transport; hide some internals of the ActionSet
      use ref instead of blessed
      refcator to remove ActionSet and Transport knowledge from Engine
      factor out iterator works into a Role
      remove support for state and transition to explore more simple mechanics
      allow params to come as a list and slurped into macro matches
      use delegate methods rather than wrappers
      remove transitions but add back states
      make state and macro "private" slots
      use actionset for continuation
      move phrasebook work into a role
      tidy method naming
      rename state to prompt
      move role import to main class
      allow send_literal which does not append ors
      support for match references in macros
      trigger find_prompt to get a prompt if no prompt set
      tidy names and code
      fix bug with two matches using the same response store
      add method last_response to access last command output; also add item_at accessor for iterator
      more efficient matching based only on last line
      no need for splitting prompt which is already marshalled
      add logging
      rename to Net::CLI::Interact
      updated dist and changes for new dist name, removed NAS shortcut
      update logger to use Log::Dispatch system and levels
      tweak log level
      move shipped phrasebooks into module structure and fix code to find them
      implement user configurable timeout
      document Iterator and move _sequence to be in Role
      add pod for the logger Role
      pod for Phrasebook
      document the Engine in pod, and update prompt set after running find_prompt
      add pod for Transport
      convert to use a family of objects rather than a single god object. still not quite a Mediator pattern, though
      no need for logger in the engine role
      no need to ignore test file
      allow quoted whitespace for send, just like follow
      change meaning of literal to disable sprintf as well
      Revert "change meaning of literal to disable sprintf as well"
      implement default continuations
      implement wake_up and find_prompt retries count
      load_phrasebooks happens automatically on new Phrasebook
      change literal for no_ors
      a little start on main module docs
      make transport connect native to engine
      fix some bugs
      add a bit more docs
      rename to default_continuation in actionset to differentiate from continuation in action
      quote escape the prompt
      auto connect now in engine execute_actions
      make some logging messages more clear
      update ignore for this dist name
      update main pod page
      change Transport to be a base class
      change location of default contiuation
      Revert "change Transport to be a base class"
      alter irs to be a regexpref using coerction from string
      fix phrasebook to accept macro name for continuation, converted to ActionSet
      fix pod to refer to retval of cmd and macro
      basic docs for Action
      basic docs for ActionSet
      flesh out Logger docs and add log_at method to main class
      fix line wrapping on POD
      move where default_continuation is, from phrasebook to main class
      update Phrasebook pod
      documentation for Engine, and set wantarray on last_response
      documentation for Prompt
      tidy Iterator docs
      make find_prompt also do connect if not connected
      cleanup Transport docs
      many pod fixes
      add Test Transport
      first test, and fixes for that
      support hashref or list params to new
      numerous wmall fixes for exposed bugs
      add more tests
      add actionset tests and add more phrasebook tests
      fix pb bug and add action tests
      make phrasebook barf when it doesnt know what to do with a line
      fix to force next on pb parsing
      change cmd and macro to use options hash
      change log_at to be a param to new
      change to be set_global_log_at
      fix log_at
      change macro and prompt to be accessor not exposed hashref
      make handling of mediator class params more automagical
      no need for attribute on the mediated trait
      change transport_options for connect_options, and enforce hash content checks
      document prompt and macro accessor methods
      implement checking of cmd and macro options
      fix bugs in param ordering
      fix doc formatting
      somewhat working but still buggy version of marshall_responses
      yay! working marshalling of response output \o/
      fix tests after pb changes
      tidy test output
      enhance description of irs_re in docs
      fix test comment
      Bumped changelog following rel. v1.110890
      Bumped changelog following rel. v1.110891
      POD fixups; try to ignore internal package namespaces
      force Pod::Weaver to put PURPOSE at top
      Bumped changelog following rel. v1.110900
      Fix "private" packages scoping so that Dist::Zilla works
      new tutorial pod
      add NAME sections to POD docs
      Bumped changelog following rel. v1.110910
      minor pod formatting typos fixed
      Bumped changelog following rel. v1.110911
      many small fixes for Win32 support, and also latent bugs
      remove command properly under win32
      improve cross platform support - now asks for plink.exe if not provided
      include xt
      make xt route test only pass plink for win32
      hide info from command
      create SSH and Serial transports
      make parity of Serial transport an enum
      change Transport role to be a base class
      move Test transport into the tests lib dir
      rename phrasebook and fix dos line endings
      move testing phrasebook into tests dir
      import Net::Appliance::Phrasebook phrasebook
      add prompt_looks_like and tidy up prompt()
      implement ability to change loaded phrasebook at any time
      implement custom match for cmd()
      add cookbook notes about setting the phrasebook
      add tests for cmd() custom match, add disconnect method to transport, fix a couple minor bugs
      add tests for loading new phrasebook
      add test for prompt_looks_like
      add Phrasebook pod
      Bumped changelog following rel. v1.111150
      fix ref to Transport.pm as Role
      fix pod linking to phrasebook details
      add table to Phrasebooks list
      support for multiple match regexps
      add check and test for timeout of 0
      patch doc for multi match in cmd()
      linux shell and ssh tests (not fully working yet)
      better version of previous (I dislike rebase)
      add support for needs_pty so that only ssh transport gets one
      dtrt on Win32 for SSH transport
      hack for test - ssh unreliable ?
      fix disconnect on Win32
      add new Platform switcher for Transport
      rename send_no_ors as put
      new cross platform backend with working Unix support
      minor typo fixes
      fix for SDF login on Win32
      fix to allow list to put() under Unix
      move one test to public tests
      implement child reaping optionally
      make the options role a package to extend, allow per-platform options
      disconnect does not have a return status
      tidy up documentation for new platform backend
      Bumped changelog following rel. v1.111500
      Set is_lazy on cmd match which is a prompt name
      fix bug and phrasebook
      ham fisted attempt to support multi matches
      cleaned up accessing the action value, somewhat
      add coerce to match param to cmd to permit single vals
      tidy code and add multi match to priv macro
      update changelog and pod
      phrasebook fixes
      Bumped changelog following rel. v1.111530
      support more SSH options, handle username properly
      Bumped changelog following rel. v1.111590
      use_net_telnet_connection is checked even on Win32
      make add_library DTRT when you want both lib and add_lib
      update gitignore
      Bumped changelog following rel. v1.112190
      Set quotemeta when stripping command from returned output (V. Foitzik)
      Bumped changelog following rel. v1.112600
      aggressively replace line end chars with \n
      Bumped changelog following rel. v1.112601
      Newline only added if there was a new *line* in output
      Bumped changelog following rel. v1.112602
      Escape embedded % in cmd() commands (B. Hogden)
      Bumped changelog following rel. v1.112610
      add has_prompt and has_macro subs
      set SDF test to disable strict host key checking
      add Foundry phrasebook from Vincent Magnin
      update Changes
      Bumped changelog following rel. v1.113600
      new implementation of transport do_action
      make test engine produce prompt without newline, which is more correct
      update POD for new line ending rules
      undef fix for Win32 disconnect()
      update Changes
      Bumped changelog following rel. v1.113610
      ors attribute should be writeable
      Bumped changelog following rel. v1.120040
      Bumped changelog following rel. v1.120042
      fix typo (C. Vicente)
      fix typo (C. Vicente)
      fix Win32 path to locate plink.exe
      Bumped changelog following rel. v1.120560
      Fix IO::Pty dependency only to appear on non-Win32. This has required a
      Bumped changelog following rel. v1.120670
      Detect connection failures and die with buffered transport error
      update tests for new sdfeu.org account
      Bumped changelog following rel. v1.121570
      NCI library version number is logged at instatiation.
      Bumped changelog following rel. v1.121640
      add Port number and generic Opts support to Telnet transport
      make sure the timeout test ssh times out before NCI
      fix undef warning when pump() on unix
      Bumped changelog following rel. v1.121990_002
      fix POD error in link to Net::Telnet
      fix POD for reap setting
      Bumped changelog following rel. v1.122010
      Add macros for paging for HP
      Bumped changelog following rel. v1.122011_001
      add POD mention of enable_paging and disable_paging in HP
      fix missing keywords in hp pb
      allow multiple wake-ups
      add prompt for NAS testing
      Bumped changelog following rel. v1.122020_002
      change docs for wake_up to formalise integer
      Bumped changelog following rel. v1.122100
      added notice log message with last_prompt
      upgrade a couple of debug messages
      upgrade connecting log to level notice
      Delete SIGCHLD after close (rt.cpan#79450)
      relax test response
      eval wrapper for test
      Bumped changelog following rel. v1.122530
      port from Moose to Moo
      Bumped changelog following rel. v2.122630
      use MakeMaker::Custom plugin to have a more complex override for IO::Pty
      test for local compiler is used for IO::Pty
      add bash support to phrasebook
      add requirements for new phrasebooks
      Squashed commit of the following:
      Squashed commit of the following:
      update changes
      Smarter log message for output matching prompt
      the prompts named "prompt" are now called "generic"
      permit ASCII escape \033 in device output
      refactor phrasebook load to use inheritance properly
      reorg phrasebook POD
      added Loopback transport for testing
      find_prompt now stores a full ActionSet after success
      Bumped changelog following rel. v2.122730
      Bug fix for wrong type spec on log_at (wmdopple, closes #9)
      Bumped changelog following rel. v2.122940
      Bug fix for wrong type spec on log_config (A. Friedrich)
      Bumped changelog following rel. v2.123270
      Change command remove to be less greedy with whitespace (C. Bennett)
      Bumped changelog following rel. v2.123300_001
      Change command remove to be less greedy with whitespace (C. Bennett)
      Fix loading of Data::Printer for last_actionset debug
      Bumped changelog following rel. v2.123370_002
      Bumped changelog following rel. v2.123610
      Remove redundant Net::Telnet->open() (closes #10, closes #11)
      Bumped changelog following rel. v2.123611
      add log_category and default_log_categories, add dialogue log class for send/response
      update changes and add logging cookbook stuff
      Bumped changelog following rel. v2.123612
      Change default_log_categories from an array to a class method
      Bumped changelog following rel. v2.123620
      Fix bug in debug log using native print instead of Logger (D. Thomas)
      Fix bug in setting of log_config after session instantiation (D. Thomas)
      Bumped changelog following rel. v2.130880
      fix for applying default timeout
      Bumped changelog following rel. v2.131260
      Make command removal substitute params as well
      Bumped changelog following rel. v2.133420
      For some reason timeout not being set? Set on Net::Telnet::get
      Bumped changelog following rel. v2.141520
      Resepct timeout in find_prompt (Jørgen Elgaard Larsen)
      Bumped changelog following rel. v2.142010
      Fix cmd in scalar context appends a newline
      Bumped changelog following rel. v2.142720

Victor Foitzik (1):
      Fixed minor typos in documentation.

gregor herrmann (1):
      Imported Upstream version 2.142720

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-perl/packages/libnet-cli-interact-perl.git



More information about the Pkg-perl-cvs-commits mailing list