[libclass-load-perl] annotated tag upstream/0.23 created (now 1c32f50)
gregor herrmann
gregoa at debian.org
Sat Jun 27 22:04:38 UTC 2015
This is an automated email from the git hooks/post-receive script.
gregoa pushed a change to annotated tag upstream/0.23
in repository libclass-load-perl.
at 1c32f50 (tag)
tagging 666a50c3d933c8a70e2ac5222c492ebcbe4c2dd6 (commit)
replaces upstream/0.22
tagged by gregor herrmann
on Sat Jun 27 23:57:32 2015 +0200
- Log -----------------------------------------------------------------
Upstream version 0.23
Caleb Cushing (1):
add test messages to the tests
Dave Rolsky (105):
Add version checking via all entry paths to the code
Clean up error handling a bit, and make sure to check if version is defined, not if its true
Fix spelling error in comment
use done_testing in all tests
First stage of implementing PP/XS versions of Class::Load - PP version is working
Add a shim module so that we can easily copy tests from this distro to Class-Load-XS
Handle difference between PP & XS case for $ISA in package
Add load_first_existing_class
Add a test for a corner case bug that was in the Class::MOP test suite
Add corner case test from Class::MOP test suite
Don't pass an undef $options to is_class_loaded, to avoid errors from XS implementation
switch to dzil
dzilize distro
Fix spelling of i.e.
Update .gitignore
add some pod tests
Add test for version object in $VERSION
Bump version
Fix name
Loading version in a package causes false positives for is_class_loaded
Handle an object in $VERSION correctly
Say what implementation of the code the tests are using
Changes for next version
Add _implementation sub for tests
v0.07
Pod fix
Add prereq on Data::OptList
Bump version
Changes for 0.08
v0.08
Remove extra whitespace
use _is_module_name everywhere internally
Changes for 0.09
Bump version
v0.09
Bump version
v0.10
Add some tests from Kent Fredric for false positives on bad modules
rename files and improve test descriptions
Make failing test a $TODO
Add more tests for false positives
Fix comment typos
changelog for starts with digit fix
add missing package
Test more bad module names
Clean up code formatting and add some more bad names
Add changes for Module::Runtime use
Bump version
v0.11
Bump Module::Runtime dep to latest
Changes for next version
Bump version
v0.12
Add test for when no implementation is available
Add a test for a bad $Class::Load::IMPLEMENTATION value
Add a test that there is no warning from loading Class::Load when ::XS is not available
Shut up "used only once" warning
We need to use the catch from Try::Tiny to get the exception value
Changes for next release
Actually require Module::Runtime 0.011 in code too
Bump version
Need Test::Requires
v0.13
Use Module::Implementation to handle loading XS or PP version
Changes for 0.14
Small formatting tweak
Use AutoPrereqs
Bump version
v0.14
Accomodate latest changes to Module::Implementation
Changes for 0.14
Bump version
Sort test prereqs
v0.15
Require Module::Runtime 0.012
Changes for next release
Bump version
v0.16
Changes for next release
Bump version
v0.17
Require Package::Stash 0.14+
Changes for next release
Bump version
v0.18
Make Changes formatting more consistent
Fix spelling, formatting, and tweak test description
s/"/'/g as needed
Tidy this t/003-load.t
Test descriptions for all tests
Make load_class() return the class name on success
No need for Pod::Coverage::Moose
A bunch of Cleanup on error throwing
Tweak Changes formatting
Add RT reference for load_class returns name
Bump version
v0.19
Merge remote-tracking branch 'doy/master'
Bump version
Changes for next release
v0.20
Fix my grammarly
Clarify my gibberish
Add tests for handling of weird constants.
Fix comment typoe
Jesse Luehrs (16):
global variables are gross
add a few more special cases here
explicitly use Scalar::Util
there's no reason to have different behavior here
fix shawn's name
use package::stash
use try::tiny
this is unnecessary
don't allow invalid module names
make sure the $@ localization doesn't hide errors
package names can't start with digits
use Module::Runtime
stop relying on %INC here, it's not actually safe
changelog and version bump
v0.19
reenable linkcheck plugin
Karen Etheridge (30):
minor comment fixes
switch to my pluginbundle
canonical repository moved to https://github.com/moose/Class-Load
add missing prereqs
Class-Load-0.21
remove unneeded shebangs
add contributors to metadata and pod
tighten up entries
remove unnecessary plugin
use the new surgical config option for more succinct configuration
now using [Git::Contributors]
add irc channel and mailing list info to metadata
try to keep our namespaces clean(ish)
leave a blank like for [PkgVersion] to insert into
capitalize abstract; move it up
add keywords to metadata
add reference to Module::Runtime (RT#97853)
document some caveats - e.g. see RT#63013
remove unneeded pod
Class-Load-0.22
avoid namespace tests for now
Coverage for Class::Load::PP is 0.0%, with 1 naked subroutine: is_class_loaded
add a placeholder .mailmap
hardcode the distribution name in Changes, to reduce churn on each release
since we are still targeting perl 5.6, only use MakeMaker to build
keep $VERSION right in the repo
switch to my podweaver plugin bundle
remove unneeded module
avoid having to clean our namespaces by avoiding importing (most) things
Class-Load-0.23
Kent Fredric (8):
fatalize 0003-load-class.t
Move Test::Exception -> Test::Fatal
update changelog
Patches to make double-load error conditions more obvious/guarantee a fail on 5.8
+Added load optional code and docs
Update changelog
Add to export
Fix errors, add tests
Shawn M Moore (17):
Cargo cult CMOP's old pure-perl is_class_loaded
Changes and version
Bump Module::Install, set repository
Re-add inc
gitignore
Remove shebang
Doc tweaks
Bump to 0.06
Be more explicit about try_load_class's contextual return
Give doy credit
Small prose fixes
0.06 and its changes
Bump Module::Install to 1.00
Better SEE ALSO
Bump Copyright to 2010
Less boilerplate
Link to tokuhirom's blog post
Shawn Moore (33):
layout, working on this later :)
the API
A failing test!
The first file will be is-class-loaded
Step 1: check %INC
A module that defines @ISA is loaded
Method ISA works too
$VERSION's cool too
Check for methods, (failing) tests for ONLY @ISA and $VERSION
Allow $ISA and @VERSION because checking the globref autovivifies :/
Implementations of load_class and try_load_class, some tests
croak, don't die
If we fail to load a class, remove traces from it from %INC so is_class_loaded returns false
More tests!
Ensure that is_class_loaded is used before trying to load a class
Fix test count
Rewrite the class->file mapper to take into account different OSes
Rename Class-Require to Class-Load
Begin renaming Class-Require to Class-Load
Move some files around
Not yet sure if deleting from %INC makes sense, I'll wait on it
documentation
doc fixes etc
Back down to MI 0.70
Ignore autogenerated files
Update Makefile.PL and Changes
Bump to 0.02
Ignore still more autogenerated files
Use my bps address for Class::Load
Declare dep on Test::Exception
Less ugly in the module one-liner :)
Bump to 0.03
Forgot to regen SIGNATURE; bump to 0.04
gregor herrmann (1):
Imported Upstream version 0.23
-----------------------------------------------------------------------
No new revisions were added by this update.
--
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-perl/packages/libclass-load-perl.git
More information about the Pkg-perl-cvs-commits
mailing list