[php-maint] Bug#385223: FTBS: php5-5.1.4-0.1

Bob Tanner tanner at real-time.com
Tue Aug 29 22:07:16 UTC 2006

Package: php5
Version: 5.1.4-0.1
Severity: serious
Justification: no longer builds from source

# apt-get source php5=5.1.4-0.1 
# apt-get build-dep  php5=5.1.4-0.1
E: Build-dependencies for php5=5.1.4-0.1 could not be satisfied.

# dpkg-buildpackage -sa
dpkg-checkbuilddeps: Unmet build dependencies: apache-dev (>= 1.3.23)
apache2-prefork-dev (>= 2.0.53-3)  <snip>

# apt-cache policy apache-dev
  Installed: (none)
  Candidate: 1.3.34-4

# apt-cache policy apache2-prefork-dev
  Installed: (none)
  Candidate: 2.0.55-4.1

# apt-get install apache-dev
Setting up apache-dev (1.3.34-4) ...

# apt-get install apache2-prefork-dev
The following packages will be REMOVED:
  apache-dev libdb4.4-dev


php5 requires apache-dev and apache2-prefork-dev but both cannot be installed on
the same system?

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'oldstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-1-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages php5 depends on:
ii  libapache2-mod-php5           5.1.4-0.1  server-side, HTML-embedded scripti
ii  php5-common                   5.1.4-0.1  Common files for packages built fr

php5 recommends no packages.

-- no debconf information

More information about the pkg-php-maint mailing list