[php-maint] Bug#390454: libapache2-mod-php4: wrong apache dependency
Tollef Fog Heen
tfheen at err.no
Sun Oct 1 11:09:24 UTC 2006
Justification: breaks upgrades to 2.2 and beyond
libapache2-mod-php4 has a dependency on apache2-mpm-prefork >> 2.0.52.
The ABI is broken with Apache 2.2, so it should either have a dependency
on apache2-common (which is called apache2.2-common with Apache 2.2) or
a << dependency to ensure it's not upgraded to any non-2.0-release.
Oh, and don't bother fixing this before 2.2 hits unstable, but please do
add the dependency on apache2.2-common then to avoid any such problem in
More information about the pkg-php-maint