Bug#390454: [php-maint] Bug#390454: libapache2-mod-php4: wrong apache dependency

Steve Langasek vorlon at debian.org
Wed Oct 4 06:23:51 UTC 2006

On Tue, Oct 03, 2006 at 09:02:19PM +0200, sean finney wrote:

> On Sun, 2006-10-01 at 13:09 +0200, Tollef Fog Heen wrote:
> > libapache2-mod-php4 has a dependency on apache2-mpm-prefork >> 2.0.52. 
> > The ABI is broken with Apache 2.2, so it should either have a dependency 
> > on apache2-common (which is called apache2.2-common with Apache 2.2) or 
> > a << dependency to ensure it's not upgraded to any non-2.0-release.

> > Oh, and don't bother fixing this before 2.2 hits unstable, but please do 
> > add the dependency on apache2.2-common then to avoid any such problem in 
> > the future.

> so to clarify, are you asking that we update the dependency to *only*
> apache2.2-common and remove all references to the httpd-providing
> packages?  or should we also update to include a dependency on the
> apache2.2-whatever-server?

This needs to be an *additional* dependency for the php packages; the reason
for depending on a specific mpm package still exists, but we need to depend
on the apache2.2-common package as well because this is in essence the
module ABI declaration.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon at debian.org                                   http://www.debian.org/

More information about the pkg-php-maint mailing list