[php-maint] Bug#417806: php5-curl fails to install

Miles Thompson miles.thompson at spatialview.com
Wed Apr 4 16:05:47 UTC 2007

Package: php5-curl
Version: not known, apt-cache search php5-curl returns no version
information, neither does the error message.

What happened: Attempted to install php5-curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-curl: Depends: phpapi-20051025
             Depends: php5-common (= 5.1.6-1ubuntu2.3) but
5.2.1-0.dotdeb.1 is to be installed
E: Broken packages

What I was doing:  Building PHP 5.2 from source for Ubuntu, and
configure requested that  the libcurl distribution be  reinstalled.I
installed libcurl--openssl-dev,  tried  configure again, but received
the same error, as follows:
    configure: error: Please reinstall the libcurl distribution - easy.h
should be in <curl-dir>/include/curl/

I then tried to install php5-curl: 
     sudo apt-get install php5-curl
and that is when I received the error message.

OS Version: Linux ruby 2.6.17-10-generic #2 SMP Fri Oct 13 15:34:39 UTC
2006 x86_64 GNU/Linux
C library type: lrwxrwxrwx 1 root root 11 2007-03-29 14:10
/lib/libc.so.6 -> libc-2.4.so
and version: 2.4-1ubuntu12.3

More information about the pkg-php-maint mailing list