[php-maint] Bug#495181: libapache2-mod-php5 does not install php5.conf and php5.load

Eric Meijer eric at elmweb.nl
Fri Aug 15 07:24:45 UTC 2008

Package: libapache2-mod-php5
Version: 5.2.6-2+b1
Severity: grave

How the problem was found:
On a clean lenny system I tried to install mediawiki.  I had done this 
before on an etch system where it went so smoothly I almost forgot how I 
configured it.  This time I could not get to the configuration.  The 
browser (iceweasel) appeared not know what to do with .php files when 
pointed to http://localhost/mediawiki/config:  it asked me if I wanted 
to download them (at some point I got the same complaint about .phtml file).

I tracked the problem down to the libapache2-mod-php5 package not 
installing the php5.load and php5.conf files in the 
/etc/apache2/mods-enabled/ directory, and, subsequently not enabling them.
'dpkg -S php5.conf' and 'dpkg -S php5.load' /did/ report that the files 
were there while they weren't.  I opened the deb file with 'ar x' and 
found out that the php5.load and php5.conf files were indeed present in 
the expected place.  I looked at the control files in the package but 
can see nothing that would remove the files, and my limited knowledge of 
debian packages stopped me from further understanding.  The 
/etc/apache2/mods-enabled/ directory was writable (for root), owned by 
root, group root, permissions drwxr-xr-x (and the disk was not full).
Related installed package versions:
apache2: 2.2.9-6
apache2-mpm-prefork: 2.2.9-6
apache2.2-common: 2.2.9-6
php5: 5.2.6-2
php5-common: 5.2.6-2+b1

I took the php5.load and php5.conf files from the deb archive, and 
copied them manually into /etc/apache2/mods-enabled/, used a2enmod to 
enable the php5 module for apache, and restarted the apache server.  
Then the mediawiki config url as mentioned above loaded correctly.  I 
did not use it further yet but it "seems to work now" (TM).

Related bugs:
I guess this bug may be related to bugs #463905 and #471548.  The latter 
talks about removing and reinstalling the package.  I did remove and 
reinstall the package a few times, when I was trying to get the 
mediawiki package to work.  However, the mediawiki never worked in the 
first place, and I suspect it is due to the problem with the 
libapache2-mod-php5 package, and has nothing to do with reinstalling, 
though I may be wrong of course.

I rated this bug "grave" because the php5 module is not enabled after 
installation, and cannot be enabled using a2enmod.

Hope this helps, please do ask for more info if needed.

Eric Meijer

More information about the pkg-php-maint mailing list