[php-maint] Bug#544285: Please decrease priority of libapache-* in php5 metapackage

Karl Goetz karl at kgoetz.id.au
Sun Aug 30 11:21:26 UTC 2009

Package: php5
Severity: normal

In Lenny, the Depends of php5 look like this:
Depends: libapache2-mod-php5 (>= 5.2.6.dfsg.1-1+lenny3) | libapache2-mod-php5filter (>= 5.2.6.dfsg.1-1+lenny3) | php5-cgi (>= 5.2.6.dfsg.1-1+lenny3), php5-common (>= 5.2.6.dfsg.1-1+lenny3)

This means someone with a fully functional lighttpd setup will be told
to install apache if they want to run a php application (the one which
came up specifically was phpmyadmin).
It would be nice if php5-cgi could be made the default Dependancy
instead of an apache module.


-- System Information:
Debian Release: 5.0.2
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-486
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

More information about the pkg-php-maint mailing list