[php-maint] Bug#538263: php5-imap remove packages php5 and php-pear when installing via aptitude

Alexey Murz Korepov murznn at gmail.com
Fri Jul 24 13:48:42 UTC 2009

Package: php5-imap
Version: 5.2.6.dfsg.1-1+lenny3
Severity: important

I try to install the php5-imap on my fully updated system, but it conflicts with installed php:
# aptitude install php5-imap
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
The following NEW packages will be installed:
  libc-client2007b{a} mlock{a}
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 841kB of archives. After unpacking 1810kB will be used.
The following packages have unmet dependencies:
  php5-imap: Depends: php5-common (= 5.2.6.dfsg.1-1+lenny3) but 5.2.9.dfsg.1-4 is installed.
The following actions will resolve these dependencies:

Remove the following packages:

Downgrade the following packages:
libapache2-mod-php5 [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-cli [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-common [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-gd [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-ldap [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-mcrypt [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]
php5-mysql [5.2.9.dfsg.1-4 (now) -> 5.2.6.dfsg.1-1+lenny3 (stable)]

Score is -22

Accept this solution? [Y/n/q/?]

Why I need to remove the php5 for install php5-imap?

-- System Information:
Debian Release: squeeze/sid
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

More information about the pkg-php-maint mailing list