[php-maint] Bug#619036: Bug#619036: php5: Build-Depends uninstallable

Ondřej Surý ondrej at sury.org
Mon Mar 21 11:06:43 UTC 2011

On Sun, Mar 20, 2011 at 19:41, Raphael Geissert <geissert at debian.org> wrote:
> On Sunday 20 March 2011 11:15:54 Kurt Roeckx wrote:
>> Your build-depends are uninstallable because you build-depend on
>> libdb-dev, which depends on libdb5.1-dev, and apache2-prefork-dev
>> which depends on libaprutil1-dev, which depends on libdb4.8-dev.
>> And libdb5.1-dev and libdb4.8-dev of course conflict with each
>> other.
> For apache: Stefan et al,
> Do you have any objection to switch to libdb5.1-dev (and bd on libdb-dev)?

Meanwhile I will upload php5 5.3.6-2 build-depending on libdb4.8-dev
and we will have to coordinate the next switch with apache2 I guess.

> Based on a few tests via php, databases from 4.8 and 5.1 seem to be
> compatible.

This seems to be true for even longer chain of releases from what I
remember from cyrus-imapd tests.

> In the long term, something needs to be decided and done. The former
> maintainer of db uploaded the latest version and orphaned the packages.

I guess if we create pkg-db group it could be handled quite
gracefully, I might be willing to join that group, because I maintain
quite some packages depending on db and if we can get somebody from
apache2, ldap and subversion, we would have quite strong team.

Ondřej Surý <ondrej at sury.org>

More information about the pkg-php-maint mailing list