[php-maint] Backport requirements exception for some packages (php5)

Ondřej Surý ondrej at sury.org
Mon Dec 16 11:27:03 UTC 2013

JFTR I have realized that we don't really need an exception since we
fulfill the rule to have higher version in testing than in backports.

Anyway – the backported version (5.4.x) keeps same PHPAPI (and ABI), so
there should not be any problems with compatibility with any existing
packages, and it would help the PHP users to have latest 5.4.x branch
available from backports.


On Mon, Dec 16, 2013, at 11:38, William Dauchy wrote:
> Hi Debian packport team,
> I was wondering if we have some news about the mail sent some months
> ago by Ondřej?
> On Tue, Oct 22, 2013 at 2:45 PM, Ondřej Surý <ondrej at sury.org> wrote:
> > we were discussing in the PHP maint group that we would like to provide
> > backported version of latest PHP patch release (e.g. 5.4.4 -> 5.4.21) in
> > the Debian backports.
> >
> > This is currently impossible because there's a requirement to have a
> > version in the testing first, and we have already bumped minor version
> > in unstable (5.4 -> 5.5) and there's always an ABI change between PHP
> > minor release.
> >
> > Would it be possible to get an exception from this rule, so we can
> > provide latest same-branch-upstream PHP while packaging the latest
> > upstream (5.5+) in the Debian unstable?
> >
> > We really don't want to jump through hoops by using experimental, or
> > t-p-u, but it would help the whole ecosystem by allowing this in the
> > backports.
> Thanks,
> -- 
> William

Ondřej Surý <ondrej at sury.org>
Knot DNS (https://www.knot-dns.cz/) – a high-performance DNS server

More information about the pkg-php-maint mailing list