[php-maint] Bug#865135: php7.0: please build-depend on automake, not obsolete automake1.11

Simon McVittie smcv at debian.org
Mon Jun 19 15:42:58 UTC 2017

Source: php7.0
Version: 7.0.20-2
Severity: minor
User: debian-qa at lists.debian.org
Usertags: automake1.11 automake1.11-nonpreferred

php7.0 has:

    Build-Depends: ..., automake (>= 1.11) | automake1.11, ...

That causes this package to show up in grep-dctrl results when
investigating whether this obsolete version of Automake can be removed
from Debian yet.

As of the release of Debian 9 'stretch', automake (>= 1.11) (or in fact
more correctly 1:1.11) has been available since oldoldstable
(Debian 7 'wheezy'), so the automake1.11 branch of the or-group does
not seem practically useful any more.

This package will not be tested regularly against automake1.11 by Debian
infrastructure, so it is reasonably likely that it does not in fact work
with automake1.11. If it does not (I have not tried it), then this bug
would become higher severity, and possibly release-critical.

Please consider changing the build-dependency to:

    Build-Depends: ..., automake, ...

(or automake (>= 1:1.11) if you want to be more explicit about it, but
that version has been present since oldoldstable so it does not seem
very useful to do so).


More information about the pkg-php-maint mailing list