[Pkg-postgresql-public] Re: Installing 8.1 while keeping 7.4.

Andreas Tille tillea at rki.de
Mon Apr 10 11:50:53 UTC 2006

I did the step of installing 8.1 in addition to 7.4 on a Debian testing
machine (the testing is a little bit outdated (January 2006) because I
was fearing bug #359137 on this important machine, but it should be the
same for any testing (Etch) based machine.

On Fri, 7 Apr 2006, Phil Endecott wrote:

> Unpacking replacement postgresql-contrib ...
> Preparing to replace postgresql 7.4.7-6sarge1 (using 
> ../postgresql_7.5.17_all.deb) ...


~$ apt-cache search postgresql | grep "^postgresql-[0-9].[0-9] "
postgresql-8.1 - object-relational SQL database, version 8.1 server
postgresql-7.4 - object-relational SQL database, version 7.4 server
postgresql-8.0 - object-relational SQL database, version 8.0 server

It sounds strange that you got 7.5.x ...

> Stopping PostgreSQL database server: postmaster.
> Stopping PostgreSQL database server: postmasterpg_ctl: could not find 
> /var/lib/postgres/data/postmaster.pid
> Is postmaster running?

I just faced this problem when I updated a different box that
formerly contained 7.4 which was removed (not purged) some time
ago.  I think I tried some stoping and starting the init script
while removing anything that looked like postgresql remainings in
/var/run.  It was not really clean, but I expect the reason for
this in my own hands.

In short: When I installed 8.1 besides 7.4 everything went
quite smooth.  I do not remember any problems worth mentioning.
The only source for problems I could imagine for your case is
that you forgot to change the port number of 8.1.  I tried 5433
and it works perfectly.

Kind regards and good luck



More information about the Pkg-postgresql-public mailing list