Chris.. in every install of backported postgres 9.X i have to nstall first postgres 8.X and then removed before install postgres 9.X, if not, the instalation of postgres 9.X from backported could not work in networks.. port are ghosted and hidden.. always..<div>
<br></div><div>this bug are still happening...</div><div><br></div><div>i have a Presence system and in avery client something i have to re-install postgres 9.x due thi bug.</div><div><br></div><div><br clear="all"><div><font color="#888888">Lenz McKAY Gerardo (PICCORO)</font><div>
<font color="#888888"><a href="" target="_blank"></a></font></div></div>
<br><br><div class="gmail_quote">On Thu, May 2, 2013 at 4:21 AM, Debian Bug Tracking System <span dir="ltr"><<a href="" target="_blank"></a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
This is an automatic notification regarding your Bug report<br>
which was filed against the postgresql-9.1 package:<br>
#684429: postgresql 9.1 cant allow conection: port 5432 are not visible in any case<br>
It has been closed by Christoph Berg <<a href=""></a>>.<br>
Their explanation is attached below along with your original report.<br>
If this explanation is unsatisfactory and you have not received a<br>
better one in a separate message then please contact Christoph Berg <<a href=""></a>> by<br>
replying to this email.<br>
<span class="HOEnZb"><font color="#888888"><br>
684429: <a href="" target="_blank"></a><br>
Debian Bug Tracking System<br>
Contact <a href=""></a> with problems<br>
</font></span><br><br>---------- Forwarded message ----------<br>From: Christoph Berg <<a href=""></a>><br>To: <a href=""></a><br>
Cc: <br>Date: Thu, 2 May 2013 10:47:26 +0200<br>Subject: Re: Bug#684429: postgresql 9.1 cant allow conection: port 5432 are not visible in any case<br>Re: PICCORO McKAY Lenz 2012-09-10 <<a href=""></a>><br>

> 9.1) i can now connect susessfully from any host<br>
> 9.2) remove and force purge postgres 8.X unninstall<br>
> 9.3) again install backpor/9.1 postgres<br>
> 9.4) eureka! i see the port open, and work prefectly<br>
I'll interpret "sucessfully" and "works perfectly" as the problem you<br>
had reported being solved.<br>
<a href=""></a> | <a href="" target="_blank"></a><br><br>---------- Forwarded message ----------<br>From: PICCORO McKAY Lenz <<a href=""></a>><br>
To: Debian Bug Tracking System <<a href=""></a>><br>Cc: <br>Date: Thu, 9 Aug 2012 17:00:20 -0430<br>Subject: postgresql 9.1 cant allow conection: port 5432 are not visible in any case<br>
Package: postgresql-9.1<br>
Version: 9.1.4-2~bpo60+1<br>
Severity: important<br>
I have installed the backported version of postgresql,<br>
but if instaled this release first any user can connect by remote hosts,<br>
i mean from another computer connections are impossible, the port 5432<br>
are closed<br>
even if postgres, firewall and any thing are configured without security!!!!<br>
I put all information here and<br>
I described how i solved but tthis method are not the right ok:<br>
1) i installed all components from backports in clean env,<br>
for postgres at today and sure there's no 8.X component instaled.<br>
2) i have setup with trust for all users over local o remote,<br>
using default port and listen on all address.<br>
I cannot conect, also by scaning ports i can see the postgresql port open..<br>
the firewall are all gone, no firewall rules , no other services using the port.<br>
3)i reinstaled older version 8.4 for squeeze and then i can connect again..<br>
in this process i also reinstall pgpool from 3 to 1.3<br>
4)then back to newer backported included pgpool 3 and slony from testing<br>
and now port apears by magic!<br>
THIS ITS SERIOUSLY VERY RARE, i think postgresql 8.X let remaining some files<br>
and then postgresql 9.X use and base thems..<br>
sorry for no more information i not have more time for that.. but u must see<br>
if this are in wheeze , due are a important bug that let unusefully<br>
the DBMS 9.X in next stable!!!!<br>
------- pg_hba.conf file dump:<br>
# Database administrative login by Unix domain socket<br>
local   all             postgres                                peer<br>
# TYPE  DATABASE        USER            ADDRESS                 METHOD<br>
# "local" is for Unix domain socket connections only<br>
local   all             all                                     trust<br>
# IPv4 local connections:<br>
host    all             all                                     trust<br>
------- line to listen are here:<br>
listen_addresses = '*'          # what IP address(es) to listen on;<br>
                                        # comma-separated list of addresses;<br>
                                        # defaults to 'localhost', '*' = all<br>
                                        # (change requires restart)<br>
port = 5432                             # (change requires restart)<br>
------- commands showing no ports available if host are used:<br>
root@sysdevel:/var/log# /etc/init.d/postgresql restart<br>
Restarting PostgreSQL 9.1 database server: main.<br>
root@sysdevel:/var/log# netstat -nxl | grep PGSQL<br>
unix  2      [ ACC ]     STREAM     LISTENING     940787<br>
root@sysdevel:/var/log# nmap<br>
Starting Nmap 5.00 ( <a href="" target="_blank"></a> ) at 2012-08-09 11:45 VET<br>
Interesting ports on <a href="" target="_blank"></a>:<br>
Not shown: 996 closed ports<br>
22/tcp   open  ssh<br>
80/tcp   open  http<br>
111/tcp  open  rpcbind<br>
8080/tcp open  http-proxy<br>
Nmap done: 1 IP address (1 host up) scanned in 5.55 seconds<br>
root@sysdevel:/var/log# ifconfig<br>
eth0      Link encap:Ethernet  HWaddr bc:30:5b:e3:11:48<br>
          inet addr:  Bcast:  Mask:<br>
          inet6 addr: fe80::be30:5bff:fee3:1148/64 Scope:Link<br>
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1<br>
          RX packets:57963800 errors:0 dropped:0 overruns:0 frame:0<br>
          TX packets:69683382 errors:0 dropped:0 overruns:0 carrier:0<br>
          collisions:0 txqueuelen:1000<br>
          RX bytes:37871383513 (35.2 GiB)  TX bytes:84903352963 (79.0 GiB)<br>
-- System Information:<br>
Debian Release: 6.1<br>
  APT prefers stable-updates<br>
  APT policy: (500, 'stable-updates'), (500, 'stable')<br>
Architecture: i386 (i686)<br>
Kernel: Linux 3.2.0-0.bpo.2-686-pae (SMP w/4 CPU cores)<br>
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)<br>
Shell: /bin/sh linked to /bin/dash<br>
Versions of packages postgresql-9.1 depends on:<br>
ii  libc6              2.11.3-3              Embedded GNU C Library: Shared lib<br>
ii  libcomerr2         1.41.12-4stable1      common error description library<br>
ii  libgssapi-krb5-2   1.8.3+dfsg-4squeeze6  MIT Kerberos runtime libraries - k<br>
ii  libkrb5-3          1.8.3+dfsg-4squeeze6  MIT Kerberos runtime libraries<br>
ii  libldap-2.4-2      2.4.23-7.2            OpenLDAP libraries<br>
ii  libpam0g           1.1.1-6.1+squeeze1    Pluggable Authentication Modules l<br>
ii  libpq5             9.1.4-2~bpo60+1       PostgreSQL C client library<br>
ii  libssl0.9.8        0.9.8o-4vnz1          SSL and crypto shared libraries<br>
ii  libxml2            2.7.8.dfsg-2+squeeze5 GNOME XML library<br>
ii  locales            2.11.3-3              Embedded GNU C Library: National L<br>
ii  postgresql-client- 9.1.4-2~bpo60+1       front-end programs for PostgreSQL<br>
ii  postgresql-common  130~bpo60+2           PostgreSQL database-cluster manage<br>
ii  ssl-cert           1.0.28                simple debconf wrapper for OpenSSL<br>
ii  tzdata             2012c-0squeeze1       time zone and daylight-saving time<br>
postgresql-9.1 recommends no packages.<br>
Versions of packages postgresql-9.1 suggests:<br>
pn  locales-all                   <none>     (no description available)<br>
pn  oidentd | ident-server        <none>     (no description available)<br>
Lenz McKAY Gerardo (PICCORO)<br>
<a href="" target="_blank"></a><br>