[DRE-commits] [gem2deb] 01/08: rename variable to better reveal intent

Antonio Terceiro terceiro at moszumanska.debian.org
Tue Aug 12 01:46:27 UTC 2014


This is an automated email from the git hooks/post-receive script.

terceiro pushed a commit to branch master
in repository gem2deb.

commit 616ee02a81f3e738bd2c6bd92d28ce9cffbf84e3
Author: Antonio Terceiro <terceiro at debian.org>
Date:   Sat Aug 9 22:16:07 2014 -0300

    rename variable to better reveal intent
---
 bin/dh_ruby_fixdepends | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

diff --git a/bin/dh_ruby_fixdepends b/bin/dh_ruby_fixdepends
index e65c3a5..0502dd2 100755
--- a/bin/dh_ruby_fixdepends
+++ b/bin/dh_ruby_fixdepends
@@ -27,17 +27,15 @@ include Gem2Deb
     if l =~ /^shlibs:Depends=/
       deps = l.chomp.split('=', 2)[1].split(', ')
       std_deps = []
-      ruby_deps = []
+      libruby_deps = []
       deps.each do |dep|
         if SUPPORTED_RUBY_SHARED_LIBRARIES.include?(dep.split(' ')[0])
-          ruby_deps << dep
+          libruby_deps << dep
         else
           std_deps << dep
         end
       end
-      # p ruby_deps
-      # p std_deps
-      newdeps = (std_deps + [(ruby_deps.join(' | '))]).join(', ')
+      newdeps = (std_deps + [(libruby_deps.join(' | '))]).join(', ')
       fd.puts "shlibs:Depends=#{newdeps}"
     else
       fd.puts l

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-ruby-extras/gem2deb.git



More information about the Pkg-ruby-extras-commits mailing list