Bug#178194: should work more cooperative on latin1<->utf-8 recoding failures

Stefano Zacchiroli Stefano Zacchiroli <zack@debian.org>, 178194@bugs.debian.org
Sun, 8 May 2005 11:37:34 +0200

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

tags 178194 + unreproducible moreinfo

Are you still able to reproduce this bug with vim 6.3?
If yes please provide a way to reproduce it.

I tried the following:
- open vim (encoding set per default to iso-8859-15
- insert some latin text ('o' with acute accent, codepoint U+00F3)
- switch encoding to utf8
- insert some cyrillic text (capital letther 'zhe', codepoint U+0416)
- save the file
And all worked properly. When I open the file I'm able per default to
see the latin text, switching to utf8 makes me able to see the cyrillic
one (and no longer the cyrillic text of course) and vice versa.


Stefano Zacchiroli -*- Computer Science PhD student @ Uny Bologna, Italy
zack@{cs.unibo.it,debian.org,bononia.it} -%- http://www.bononia.it/zack/
If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. -!-

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.0 (GNU/Linux)