Bug#380244: vim doesn't yank properly

Khosrow Hassani khosrokhan at yahoo.com
Fri Jul 28 18:54:53 UTC 2006

 I know there are other ways to copy, but I wanted to do it the standard way Vi does. also, I wanted to fix the problem for ever not for this time.
 I did not copy from a registry. here is what I exactly did:
 opened file1: vim file1
 while in file1, opened file2:  :e file2
 scrolled down and yanked some lines: 20yy
 switched back to file1:  ctrl-6
 paste the lines: p
 the lines copied were not what I had yanked!
 funny thing is that instead of file1, I repeated with another file, foo and it worked fine!! so, I don't think it has anything to do with my .vimrc file. this is probably a bug in vim.
 thanks anyway,

James Vega <jamessan at debian.org> wrote: On Fri, Jul 28, 2006 at 10:52:14AM -0700, Khosrow Hassani wrote:
> James Vega  wrote: On Fri, Jul 28, 2006 at 09:24:51AM -0700, Khosrow Hassani wrote:
> > > Package: Vim
> > >  Version: 1:6.3-071+1sarge1
> > >  
> > >  I am editing my_file and switch to another file (:e second_file) and
> > >  yank some lines. when I go back to the original file, my_file by
> > >  CTRL-6 and press "p" to copy the yanked lines, I get some other
> > >  garbage lines I had never yanked!!
> > 
> > First, try starting Vim with the "-u NONE -N" arguments.  Can you
> > reproduce the problem?  If so, give exact steps on how to replicate the
> > problem.  Keys pressed, commands run, etc.  If you aren't able to
> > reproduce the problem, try starting Vim with the "-u /etc/vim/vimrc -N"
> > arguments.
> > 
> > If you are still unable to reproduce it, then the problem would seem to
> > be something in your ~/.vimrc or ~/.vim/ files.
> Hi,
>  with -u NONE -N options it worked fine. with -u /etc/vim/vimrc -N  I
>  had the exact same problem! no unusual steps, I just did what I
>  reported before, a simple copy.

There a many different ways to copy and paste.  You can use the mouse,
copy from normal mode, copy from visual mode, copy from command line
mode.  I also have no idea whether you copied into or pasted from a

In order to be able to reproduce what happened and give some help, I
would need to know exactly what you did.  A minimal set of steps to see
the same behavior is very helpful.

GPG Key: 1024D/61326D40 2003-09-02 James Vega 

growing OLD is mandatory, growing UP is optional !
Do you Yahoo!?
 Everyone is raving about the  all-new Yahoo! Mail Beta.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/pkg-vim-maintainers/attachments/20060728/b7fd257a/attachment.html

More information about the pkg-vim-maintainers mailing list