Bug#503757: vim-runtime: Installation fails

Noah Meyerhans noahm at debian.org
Mon Nov 3 23:11:51 UTC 2008

On Sat, Nov 01, 2008 at 10:52:01PM -0400, James Vega wrote:
> On Fri, Oct 31, 2008 at 11:49:26PM -0400, Noah Meyerhans wrote:
> > I've managed to reproduce this.  It seems to only happen when upgrading
> > from 1:7.1.314-3 to 2:7.2.*  Even the version currently in lenny
> > (1:7.1.314-3+lenny2) upgrades fine.  I had to go through
> > archive.debian.net to get the specific version that fails.
> Could you give exact steps to reproduce this?  I tried by "dpkg -i
> vim-common vim-tiny vim-runtime vim" for 7.1.314-3 and then upgrading to
> the pacakges in sid.  This worked fine.

Here's roughly how I've been able to reproduce this bug:

1. start with a minimal etch installation in a qemu image
2. Make /etc/apt/sources.list contain only one entry:
   deb http://snapshot.debian.net/snapshot/2008/06/19/debian sid main
3. apt-get update
4. apt-get install apt dpkg vim-runtime vim-tiny vim-common
   At this point the above vim-* packages are the only ones installed:
   snort:~# dpkg -l  | grep vim
   ii  vim-common     7.1.314-3      Vi IMproved - Common files
   ii  vim-runtime    7.1.314-3      Vi IMproved - Runtime files
   ii  vim-tiny       7.1.314-3      Vi IMproved - enhanced vi editor
5. Edit sources.list to refer to a current sid source
6. apt-get update
7. apt-get install vim-runtime
   This fails as reported previously.

I'm still not sure exactly who's responsible for the bug.

One thing I haven't yet done is check the dpkg diversions before step


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-vim-maintainers/attachments/20081103/fc51d2b6/attachment.pgp 

More information about the pkg-vim-maintainers mailing list