Bug#544682: vim: segfault on reading gzipped file

James Vega jamessan at debian.org
Sat Nov 7 06:14:04 UTC 2009

tag 544682 unreproducible

On Wed, Sep 02, 2009 at 07:00:37PM +0300, Eugene V. Lyubimkin wrote:
> James Vega wrote:
> > This worked fine for me when using
> > /usr/share/doc/vim-common/changelog.Debian.gz as the test file.
> Yes, this worked for me for many months, for many other compressed files. This
> is the first time I saw segfault.

Is it still reproducible for you?  I've tried to reproduce it and
haven't had any luck.  I get messages about not being able to create the
tempfile and then I'm presented with the uncompressed file, but no

> > “:help E326” explains that.  That might be related.
> Hm. "Too many swap files"?. Strange.
> I tried re-run it in other directory and it worked, however,
> -8<-
> $ ls -lah
> total 4.0K
> drwxrwxrwx 2 root root    0 1970-01-01 03:00 .
> drwxr-xr-x 9 root root 4.0K 2009-08-30 18:29 ..
> ->8-
> This directory is not user-writeable, maybe that's the reason.

I tried in a setup where there was no /tmp, $TMPDIR and $HOME were
unset, and '.' wasn't writable by the user.  Aside from being unable to
display the uncompressed text, it worked fine.

GPG Key: 1024D/61326D40 2003-09-02 James Vega <jamessan at debian.org>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-vim-maintainers/attachments/20091107/a8483a99/attachment.pgp>

More information about the pkg-vim-maintainers mailing list