[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677

mjs mjs at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 05:53:22 UTC 2009


The following commit has been merged in the debian/unstable branch:
commit 81c990cbfcb3421142b62b5e43b0a54fb9e945bb
Author: mjs <mjs at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Sat Dec 15 02:19:53 2001 +0000

    	Simplified WKLocationChangeHandler and updated
    	WKAuthenticationHandler.
    
    	* WebView.subproj/WKWebController.h:
    	(WKWebDataSource): Renamed methods to be forDataSource, not
    	byDataSource.
    	(-[WKWebDataSource locationChangeInProgressForDataSource:]): Added.
    	(-[WKWebDataSource locationChangeDone:forDataSource:]): Added as a
    	collapsed version of locationChangeCancelled:,
    	locationChangeStopped: and locationChangeFinished:.
    	(WKSimpleAuthenticationResult, WKSimpleAuthenticationRequest):
    	made these interfaces instead of structs.
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@505 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebKit/ChangeLog b/WebKit/ChangeLog
index 33a0c03..5fb3bea 100644
--- a/WebKit/ChangeLog
+++ b/WebKit/ChangeLog
@@ -1,5 +1,20 @@
 2001-12-14  Maciej Stachowiak  <mjs at apple.com>
 
+	Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler.
+
+	* WebView.subproj/WKWebController.h:
+	(WKWebDataSource): Renamed methods to be forDataSource, not
+	byDataSource.
+	(-[WKWebDataSource locationChangeInProgressForDataSource:]): Added.
+	(-[WKWebDataSource locationChangeDone:forDataSource:]): Added as a
+	collapsed version of locationChangeCancelled:,
+	locationChangeStopped: and locationChangeFinished:.
+	(WKSimpleAuthenticationResult, WKSimpleAuthenticationRequest):
+	made these interfaces instead of structs.
+	
+2001-12-14  Maciej Stachowiak  <mjs at apple.com>
+
 	Minor cleanups, mostly for naming consistency.
 	
 	* WebView.subproj/WKWebController.h: 
diff --git a/WebKit/ChangeLog-2002-12-03 b/WebKit/ChangeLog-2002-12-03
index 33a0c03..5fb3bea 100644
--- a/WebKit/ChangeLog-2002-12-03
+++ b/WebKit/ChangeLog-2002-12-03
@@ -1,5 +1,20 @@
 2001-12-14  Maciej Stachowiak  <mjs at apple.com>
 
+	Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler.
+
+	* WebView.subproj/WKWebController.h:
+	(WKWebDataSource): Renamed methods to be forDataSource, not
+	byDataSource.
+	(-[WKWebDataSource locationChangeInProgressForDataSource:]): Added.
+	(-[WKWebDataSource locationChangeDone:forDataSource:]): Added as a
+	collapsed version of locationChangeCancelled:,
+	locationChangeStopped: and locationChangeFinished:.
+	(WKSimpleAuthenticationResult, WKSimpleAuthenticationRequest):
+	made these interfaces instead of structs.
+	
+2001-12-14  Maciej Stachowiak  <mjs at apple.com>
+
 	Minor cleanups, mostly for naming consistency.
 	
 	* WebView.subproj/WKWebController.h: 
diff --git a/WebKit/WebView.subproj/IFWebController.h b/WebKit/WebView.subproj/IFWebController.h
index 99220ff..3201f39 100644
--- a/WebKit/WebView.subproj/IFWebController.h
+++ b/WebKit/WebView.subproj/IFWebController.h
@@ -95,6 +95,9 @@
         Remove WKContextMenuHandler for want of a better way to describe the
         not-yet-existing WKDOMNode.  We can't think of any initial clients that want
         to override the default behavior anyway.  Put it in WKGrabBag.h for now.
+
+        Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler to use interfaces instead of structs..
 */
 
 
@@ -172,9 +175,8 @@
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
 - (void)locationChangeStarted;
-- (void)locationChangeCancelled: (WKError *)error;
-- (void)locationChangeStopped: (WKError *)error;
-- (void)locationChangeFinished;
+- (void)locationChangeInProgress;
+- (void)locationChangeDone: (WKError *)error;
 
 - (void)receivedPageTitle: (NSString *)title;
 
@@ -198,14 +200,13 @@
 // handshake.
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
-- (void)locationChangeStartedByDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeCancelled: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeStopped: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeFinished byDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeStartedForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeInProgressForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeDone: (WKError *)error forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)receivedPageTitle: (NSString *)title byDataSource: (WKWebDataSource *)dataSource;
+- (void)receivedPageTitle: (NSString *)title forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)serverRedirectTo: (NSURL *)url byDataSource: (WKWebDataSource *)dataSource;
+- (void)serverRedirectTo: (NSURL *)url forDataSource: (WKWebDataSource *)dataSource;
 
 @end
 
@@ -256,17 +257,18 @@
 
 */
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationResult {
+ at interface WKSimpleAuthenticationResult 
+{
     NSString *username;
     NSString *password;
     // May need an extra rememberThisPassword flag if the loader mechanism is
     // going to provide a persistent credentials cache (for starters we can have
     // just a session cache)
 }
+ at end
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationRequest {
+ at interface WKSimpleAuthenticationRequest 
+{
     NSURL *url;         // nil if for something non-URI based
     NSString *domain;   // http authentication domain or some representation of 
                         // auth domain for non-URI-based locations; otherwise nil.
diff --git a/WebKit/WebView.subproj/WKWebController.h b/WebKit/WebView.subproj/WKWebController.h
index 99220ff..3201f39 100644
--- a/WebKit/WebView.subproj/WKWebController.h
+++ b/WebKit/WebView.subproj/WKWebController.h
@@ -95,6 +95,9 @@
         Remove WKContextMenuHandler for want of a better way to describe the
         not-yet-existing WKDOMNode.  We can't think of any initial clients that want
         to override the default behavior anyway.  Put it in WKGrabBag.h for now.
+
+        Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler to use interfaces instead of structs..
 */
 
 
@@ -172,9 +175,8 @@
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
 - (void)locationChangeStarted;
-- (void)locationChangeCancelled: (WKError *)error;
-- (void)locationChangeStopped: (WKError *)error;
-- (void)locationChangeFinished;
+- (void)locationChangeInProgress;
+- (void)locationChangeDone: (WKError *)error;
 
 - (void)receivedPageTitle: (NSString *)title;
 
@@ -198,14 +200,13 @@
 // handshake.
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
-- (void)locationChangeStartedByDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeCancelled: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeStopped: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeFinished byDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeStartedForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeInProgressForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeDone: (WKError *)error forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)receivedPageTitle: (NSString *)title byDataSource: (WKWebDataSource *)dataSource;
+- (void)receivedPageTitle: (NSString *)title forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)serverRedirectTo: (NSURL *)url byDataSource: (WKWebDataSource *)dataSource;
+- (void)serverRedirectTo: (NSURL *)url forDataSource: (WKWebDataSource *)dataSource;
 
 @end
 
@@ -256,17 +257,18 @@
 
 */
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationResult {
+ at interface WKSimpleAuthenticationResult 
+{
     NSString *username;
     NSString *password;
     // May need an extra rememberThisPassword flag if the loader mechanism is
     // going to provide a persistent credentials cache (for starters we can have
     // just a session cache)
 }
+ at end
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationRequest {
+ at interface WKSimpleAuthenticationRequest 
+{
     NSURL *url;         // nil if for something non-URI based
     NSString *domain;   // http authentication domain or some representation of 
                         // auth domain for non-URI-based locations; otherwise nil.
diff --git a/WebKit/WebView.subproj/WebController.h b/WebKit/WebView.subproj/WebController.h
index 99220ff..3201f39 100644
--- a/WebKit/WebView.subproj/WebController.h
+++ b/WebKit/WebView.subproj/WebController.h
@@ -95,6 +95,9 @@
         Remove WKContextMenuHandler for want of a better way to describe the
         not-yet-existing WKDOMNode.  We can't think of any initial clients that want
         to override the default behavior anyway.  Put it in WKGrabBag.h for now.
+
+        Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler to use interfaces instead of structs..
 */
 
 
@@ -172,9 +175,8 @@
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
 - (void)locationChangeStarted;
-- (void)locationChangeCancelled: (WKError *)error;
-- (void)locationChangeStopped: (WKError *)error;
-- (void)locationChangeFinished;
+- (void)locationChangeInProgress;
+- (void)locationChangeDone: (WKError *)error;
 
 - (void)receivedPageTitle: (NSString *)title;
 
@@ -198,14 +200,13 @@
 // handshake.
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
-- (void)locationChangeStartedByDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeCancelled: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeStopped: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeFinished byDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeStartedForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeInProgressForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeDone: (WKError *)error forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)receivedPageTitle: (NSString *)title byDataSource: (WKWebDataSource *)dataSource;
+- (void)receivedPageTitle: (NSString *)title forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)serverRedirectTo: (NSURL *)url byDataSource: (WKWebDataSource *)dataSource;
+- (void)serverRedirectTo: (NSURL *)url forDataSource: (WKWebDataSource *)dataSource;
 
 @end
 
@@ -256,17 +257,18 @@
 
 */
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationResult {
+ at interface WKSimpleAuthenticationResult 
+{
     NSString *username;
     NSString *password;
     // May need an extra rememberThisPassword flag if the loader mechanism is
     // going to provide a persistent credentials cache (for starters we can have
     // just a session cache)
 }
+ at end
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationRequest {
+ at interface WKSimpleAuthenticationRequest 
+{
     NSURL *url;         // nil if for something non-URI based
     NSString *domain;   // http authentication domain or some representation of 
                         // auth domain for non-URI-based locations; otherwise nil.
diff --git a/WebKit/WebView.subproj/WebView.h b/WebKit/WebView.subproj/WebView.h
index 99220ff..3201f39 100644
--- a/WebKit/WebView.subproj/WebView.h
+++ b/WebKit/WebView.subproj/WebView.h
@@ -95,6 +95,9 @@
         Remove WKContextMenuHandler for want of a better way to describe the
         not-yet-existing WKDOMNode.  We can't think of any initial clients that want
         to override the default behavior anyway.  Put it in WKGrabBag.h for now.
+
+        Simplified WKLocationChangeHandler and updated
+	WKAuthenticationHandler to use interfaces instead of structs..
 */
 
 
@@ -172,9 +175,8 @@
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
 - (void)locationChangeStarted;
-- (void)locationChangeCancelled: (WKError *)error;
-- (void)locationChangeStopped: (WKError *)error;
-- (void)locationChangeFinished;
+- (void)locationChangeInProgress;
+- (void)locationChangeDone: (WKError *)error;
 
 - (void)receivedPageTitle: (NSString *)title;
 
@@ -198,14 +200,13 @@
 // handshake.
 - (BOOL)locationWillChangeTo: (NSURL *)url;
 
-- (void)locationChangeStartedByDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeCancelled: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeStopped: (WKError *)error byDataSource: (WKWebDataSource *)dataSource;
-- (void)locationChangeFinished byDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeStartedForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeInProgressForDataSource: (WKWebDataSource *)dataSource;
+- (void)locationChangeDone: (WKError *)error forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)receivedPageTitle: (NSString *)title byDataSource: (WKWebDataSource *)dataSource;
+- (void)receivedPageTitle: (NSString *)title forDataSource: (WKWebDataSource *)dataSource;
 
-- (void)serverRedirectTo: (NSURL *)url byDataSource: (WKWebDataSource *)dataSource;
+- (void)serverRedirectTo: (NSURL *)url forDataSource: (WKWebDataSource *)dataSource;
 
 @end
 
@@ -256,17 +257,18 @@
 
 */
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationResult {
+ at interface WKSimpleAuthenticationResult 
+{
     NSString *username;
     NSString *password;
     // May need an extra rememberThisPassword flag if the loader mechanism is
     // going to provide a persistent credentials cache (for starters we can have
     // just a session cache)
 }
+ at end
 
-/* should this be an interface instead? */
-struct WKSimpleAuthenticationRequest {
+ at interface WKSimpleAuthenticationRequest 
+{
     NSURL *url;         // nil if for something non-URI based
     NSString *domain;   // http authentication domain or some representation of 
                         // auth domain for non-URI-based locations; otherwise nil.

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list