[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677
darin
darin at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 07:57:12 UTC 2009
The following commit has been merged in the debian/unstable branch:
commit d3f55ef532df7156223650c63bac367b7fd565e7
Author: darin <darin at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Wed Sep 24 15:55:20 2003 +0000
Reviewed by Ken.
- fixed ownerElement for documents in HTML objects (helpful for some work Dave is doing)
* khtml/khtml_part.h: Change name of frame function to childFrame for clarity.
* khtml/khtml_part.cpp:
(KHTMLPart::slotChildStarted): Call the frame function by its new name, childFrame.
(KHTMLPart::slotChildCompleted): Ditto.
(KHTMLPart::slotChildURLRequest): Ditto.
(KHTMLPart::childFrame): Change name from frame to childFrame for clarity, and make it work
for parts inside HTML objects, not just normal frames and iframes. The change in behavior is
the actual fix. Note that for the three callers above, it's an error to call this when the
result would be 0, so there's no harm in doing the extra search of HTML objects in those cases.
* khtml/xml/dom_docimpl.cpp: (DocumentImpl::ownerElement): Call the frame function by its new
name, childFrame. This is the caller that will benefit most from the change in behavior.
* kwq/KWQKHTMLPart.h: Remove childFrameForPart function, which is superseded by the
childFrame function now.
* kwq/KWQKHTMLPart.mm: (KWQKHTMLPart::nextKeyViewInFrameHierarchy): Use childFrame instead
of childFrameForPart.
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@5043 268f45cc-cd09-0410-ab3c-d52691b4dbfc
diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index 10c1d04..6368329 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,3 +1,27 @@
+2003-09-24 Darin Adler <darin at apple.com>
+
+ Reviewed by Ken.
+
+ - fixed ownerElement for documents in HTML objects (helpful for some work Dave is doing)
+
+ * khtml/khtml_part.h: Change name of frame function to childFrame for clarity.
+ * khtml/khtml_part.cpp:
+ (KHTMLPart::slotChildStarted): Call the frame function by its new name, childFrame.
+ (KHTMLPart::slotChildCompleted): Ditto.
+ (KHTMLPart::slotChildURLRequest): Ditto.
+ (KHTMLPart::childFrame): Change name from frame to childFrame for clarity, and make it work
+ for parts inside HTML objects, not just normal frames and iframes. The change in behavior is
+ the actual fix. Note that for the three callers above, it's an error to call this when the
+ result would be 0, so there's no harm in doing the extra search of HTML objects in those cases.
+
+ * khtml/xml/dom_docimpl.cpp: (DocumentImpl::ownerElement): Call the frame function by its new
+ name, childFrame. This is the caller that will benefit most from the change in behavior.
+
+ * kwq/KWQKHTMLPart.h: Remove childFrameForPart function, which is superseded by the
+ childFrame function now.
+ * kwq/KWQKHTMLPart.mm: (KWQKHTMLPart::nextKeyViewInFrameHierarchy): Use childFrame instead
+ of childFrameForPart.
+
2003-09-23 Darin Adler <darin at apple.com>
Reviewed by Ken.
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index 10c1d04..6368329 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,3 +1,27 @@
+2003-09-24 Darin Adler <darin at apple.com>
+
+ Reviewed by Ken.
+
+ - fixed ownerElement for documents in HTML objects (helpful for some work Dave is doing)
+
+ * khtml/khtml_part.h: Change name of frame function to childFrame for clarity.
+ * khtml/khtml_part.cpp:
+ (KHTMLPart::slotChildStarted): Call the frame function by its new name, childFrame.
+ (KHTMLPart::slotChildCompleted): Ditto.
+ (KHTMLPart::slotChildURLRequest): Ditto.
+ (KHTMLPart::childFrame): Change name from frame to childFrame for clarity, and make it work
+ for parts inside HTML objects, not just normal frames and iframes. The change in behavior is
+ the actual fix. Note that for the three callers above, it's an error to call this when the
+ result would be 0, so there's no harm in doing the extra search of HTML objects in those cases.
+
+ * khtml/xml/dom_docimpl.cpp: (DocumentImpl::ownerElement): Call the frame function by its new
+ name, childFrame. This is the caller that will benefit most from the change in behavior.
+
+ * kwq/KWQKHTMLPart.h: Remove childFrameForPart function, which is superseded by the
+ childFrame function now.
+ * kwq/KWQKHTMLPart.mm: (KWQKHTMLPart::nextKeyViewInFrameHierarchy): Use childFrame instead
+ of childFrameForPart.
+
2003-09-23 Darin Adler <darin at apple.com>
Reviewed by Ken.
diff --git a/WebCore/khtml/khtml_part.cpp b/WebCore/khtml/khtml_part.cpp
index 7bef1bc..b4f2fa1 100644
--- a/WebCore/khtml/khtml_part.cpp
+++ b/WebCore/khtml/khtml_part.cpp
@@ -3492,7 +3492,7 @@ void KHTMLPart::slotParentCompleted()
void KHTMLPart::slotChildStarted( KIO::Job *job )
{
- khtml::ChildFrame *child = frame( sender() );
+ khtml::ChildFrame *child = childFrame( sender() );
assert( child );
@@ -3519,7 +3519,7 @@ void KHTMLPart::slotChildCompleted()
void KHTMLPart::slotChildCompleted( bool complete )
{
- khtml::ChildFrame *child = frame( sender() );
+ khtml::ChildFrame *child = childFrame( sender() );
assert( child );
@@ -3536,7 +3536,7 @@ void KHTMLPart::slotChildCompleted( bool complete )
void KHTMLPart::slotChildURLRequest( const KURL &url, const KParts::URLArgs &args )
{
- khtml::ChildFrame *child = frame( sender()->parent() );
+ khtml::ChildFrame *child = childFrame( sender()->parent() );
QString frameName = args.frameName.lower();
if ( !frameName.isEmpty() )
@@ -3594,7 +3594,7 @@ void KHTMLPart::slotChildURLRequest( const KURL &url, const KParts::URLArgs &arg
#endif // APPLE_CHANGES
-khtml::ChildFrame *KHTMLPart::frame( const QObject *obj )
+khtml::ChildFrame *KHTMLPart::childFrame( const QObject *obj )
{
assert( obj->inherits( "KParts::ReadOnlyPart" ) );
const KParts::ReadOnlyPart *part = static_cast<const KParts::ReadOnlyPart *>( obj );
@@ -3602,7 +3602,13 @@ khtml::ChildFrame *KHTMLPart::frame( const QObject *obj )
FrameIt it = d->m_frames.begin();
FrameIt end = d->m_frames.end();
for (; it != end; ++it )
- if ( (KParts::ReadOnlyPart *)(*it).m_part == part )
+ if ( (*it).m_part == part )
+ return &(*it);
+
+ it = d->m_objects.begin();
+ end = d->m_objects.end();
+ for (; it != end; ++it )
+ if ( (*it).m_part == part )
return &(*it);
return 0L;
diff --git a/WebCore/khtml/khtml_part.h b/WebCore/khtml/khtml_part.h
index 363b62d..845213d 100644
--- a/WebCore/khtml/khtml_part.h
+++ b/WebCore/khtml/khtml_part.h
@@ -1069,7 +1069,7 @@ private:
DOM::HTMLDocumentImpl *docImpl() const;
DOM::DocumentImpl *xmlDocImpl() const;
- khtml::ChildFrame *frame( const QObject *obj );
+ khtml::ChildFrame *childFrame( const QObject *obj );
khtml::ChildFrame *recursiveFrameRequest( const KURL &url, const KParts::URLArgs &args, bool callParent = true );
diff --git a/WebCore/khtml/xml/dom_docimpl.cpp b/WebCore/khtml/xml/dom_docimpl.cpp
index 22c5fb9..b969d92 100644
--- a/WebCore/khtml/xml/dom_docimpl.cpp
+++ b/WebCore/khtml/xml/dom_docimpl.cpp
@@ -2298,7 +2298,7 @@ ElementImpl *DocumentImpl::ownerElement()
KHTMLPart *parent = childPart->parentPart();
if (!parent)
return 0;
- ChildFrame *childFrame = parent->frame(childPart);
+ ChildFrame *childFrame = parent->childFrame(childPart);
if (!childFrame)
return 0;
RenderPart *renderPart = childFrame->m_frame;
diff --git a/WebCore/kwq/KWQKHTMLPart.h b/WebCore/kwq/KWQKHTMLPart.h
index 9937076..a9ff0a6 100644
--- a/WebCore/kwq/KWQKHTMLPart.h
+++ b/WebCore/kwq/KWQKHTMLPart.h
@@ -246,7 +246,6 @@ private:
NSView *nextKeyViewInFrame(DOM::NodeImpl *startingPoint, KWQSelectionDirection);
static DOM::NodeImpl *nodeForWidget(const QWidget *);
static KWQKHTMLPart *partForNode(DOM::NodeImpl *);
- khtml::ChildFrame *childFrameForPart(const KParts::ReadOnlyPart *) const;
WebCoreBridge *_bridge;
diff --git a/WebCore/kwq/KWQKHTMLPart.mm b/WebCore/kwq/KWQKHTMLPart.mm
index c496386..642dfda 100644
--- a/WebCore/kwq/KWQKHTMLPart.mm
+++ b/WebCore/kwq/KWQKHTMLPart.mm
@@ -876,25 +876,6 @@ NSView *KWQKHTMLPart::nextKeyViewInFrame(NodeImpl *node, KWQSelectionDirection d
}
}
-ChildFrame *KWQKHTMLPart::childFrameForPart(const ReadOnlyPart *part) const
-{
- FrameIt it = d->m_frames.begin();
- FrameIt end = d->m_frames.end();
- for (; it != end; ++it) {
- if ((*it).m_part == part) {
- return &*it;
- }
- }
- it = d->m_objects.begin();
- end = d->m_objects.end();
- for (; it != end; ++it) {
- if ((*it).m_part == part) {
- return &*it;
- }
- }
- return 0;
-}
-
NSView *KWQKHTMLPart::nextKeyViewInFrameHierarchy(NodeImpl *node, KWQSelectionDirection direction)
{
NSView *next = nextKeyViewInFrame(node, direction);
@@ -904,7 +885,7 @@ NSView *KWQKHTMLPart::nextKeyViewInFrameHierarchy(NodeImpl *node, KWQSelectionDi
KWQKHTMLPart *parent = KWQ(parentPart());
if (parent) {
- next = parent->nextKeyView(parent->childFrameForPart(this)->m_frame->element(), direction);
+ next = parent->nextKeyView(parent->childFrame(this)->m_frame->element(), direction);
if (next) {
return next;
}
--
WebKit Debian packaging
More information about the Pkg-webkit-commits
mailing list