[SCM] WebKit Debian packaging branch, debian/unstable, updated. debian/1.1.15-1-40151-g37bb677
hyatt
hyatt at 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Sat Sep 26 08:03:18 UTC 2009
The following commit has been merged in the debian/unstable branch:
commit a6a22ef458419b25d3ddc0456c777e4062d953fd
Author: hyatt <hyatt at 268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Sat Oct 18 23:23:10 2003 +0000
Fix the intrinsic minmax width computation for blocks and XUL boxes to actually check fixed min/max CSS widths.
Reviewed by darin
* khtml/rendering/render_block.cpp:
(khtml::RenderBlock::calcMinMaxWidth):
* khtml/rendering/render_flexbox.cpp:
(khtml::RenderFlexibleBox::calcMinMaxWidth):
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@5213 268f45cc-cd09-0410-ab3c-d52691b4dbfc
diff --git a/WebCore/ChangeLog-2003-10-25 b/WebCore/ChangeLog-2003-10-25
index bde6a5a..8f83633 100644
--- a/WebCore/ChangeLog-2003-10-25
+++ b/WebCore/ChangeLog-2003-10-25
@@ -1,5 +1,16 @@
2003-10-18 David Hyatt <hyatt at apple.com>
+ Fix the intrinsic minmax width computation for blocks and XUL boxes to actually check fixed min/max CSS widths.
+
+ Reviewed by darin
+
+ * khtml/rendering/render_block.cpp:
+ (khtml::RenderBlock::calcMinMaxWidth):
+ * khtml/rendering/render_flexbox.cpp:
+ (khtml::RenderFlexibleBox::calcMinMaxWidth):
+
+2003-10-18 David Hyatt <hyatt at apple.com>
+
Change the names of the border-spacing properties to border-horizontal-spacing and border-vertical-spacing.
Reviewed by NOBODY (Straightforward).
diff --git a/WebCore/ChangeLog-2005-08-23 b/WebCore/ChangeLog-2005-08-23
index bde6a5a..8f83633 100644
--- a/WebCore/ChangeLog-2005-08-23
+++ b/WebCore/ChangeLog-2005-08-23
@@ -1,5 +1,16 @@
2003-10-18 David Hyatt <hyatt at apple.com>
+ Fix the intrinsic minmax width computation for blocks and XUL boxes to actually check fixed min/max CSS widths.
+
+ Reviewed by darin
+
+ * khtml/rendering/render_block.cpp:
+ (khtml::RenderBlock::calcMinMaxWidth):
+ * khtml/rendering/render_flexbox.cpp:
+ (khtml::RenderFlexibleBox::calcMinMaxWidth):
+
+2003-10-18 David Hyatt <hyatt at apple.com>
+
Change the names of the border-spacing properties to border-horizontal-spacing and border-vertical-spacing.
Reviewed by NOBODY (Straightforward).
diff --git a/WebCore/khtml/rendering/render_block.cpp b/WebCore/khtml/rendering/render_block.cpp
index ea0678f..710dbfb 100644
--- a/WebCore/khtml/rendering/render_block.cpp
+++ b/WebCore/khtml/rendering/render_block.cpp
@@ -1985,7 +1985,16 @@ void RenderBlock::calcMinMaxWidth()
else
m_minWidth = m_maxWidth = short(style()->width().value);
}
- // FIXME: also compare with min/max width CSS properties...
+
+ if (style()->minWidth().isFixed() && style()->minWidth().value > 0) {
+ m_maxWidth = KMAX(m_maxWidth, short(style()->minWidth().value));
+ m_minWidth = KMAX(m_minWidth, short(style()->minWidth().value));
+ }
+
+ if (style()->maxWidth().isFixed() && style()->maxWidth().value != UNDEFINED) {
+ m_maxWidth = KMIN(m_maxWidth, short(style()->maxWidth().value));
+ m_minWidth = KMIN(m_minWidth, short(style()->maxWidth().value));
+ }
int toAdd = 0;
toAdd = borderLeft() + borderRight() + paddingLeft() + paddingRight();
diff --git a/WebCore/khtml/rendering/render_flexbox.cpp b/WebCore/khtml/rendering/render_flexbox.cpp
index 22b457a..0923ff4 100644
--- a/WebCore/khtml/rendering/render_flexbox.cpp
+++ b/WebCore/khtml/rendering/render_flexbox.cpp
@@ -220,7 +220,16 @@ void RenderFlexibleBox::calcMinMaxWidth()
if (style()->width().isFixed() && style()->width().value > 0)
m_minWidth = m_maxWidth = short(style()->width().value);
- // FIXME: also compare with min/max width CSS properties...
+
+ if (style()->minWidth().isFixed() && style()->minWidth().value > 0) {
+ m_maxWidth = KMAX(m_maxWidth, short(style()->minWidth().value));
+ m_minWidth = KMAX(m_minWidth, short(style()->minWidth().value));
+ }
+
+ if (style()->maxWidth().isFixed() && style()->maxWidth().value != UNDEFINED) {
+ m_maxWidth = KMIN(m_maxWidth, short(style()->maxWidth().value));
+ m_minWidth = KMIN(m_minWidth, short(style()->maxWidth().value));
+ }
int toAdd = borderLeft() + borderRight() + paddingLeft() + paddingRight();
m_minWidth += toAdd;
--
WebKit Debian packaging
More information about the Pkg-webkit-commits
mailing list