[SCM] WebKit Debian packaging branch, webkit-1.2, updated. upstream/1.1.90-6072-g9a69373

yael.aharon at nokia.com yael.aharon at nokia.com
Wed Apr 7 23:44:22 UTC 2010


The following commit has been merged in the webkit-1.2 branch:
commit de060e3164858da93f41e326788f0f0e9de68cc7
Author: yael.aharon at nokia.com <yael.aharon at nokia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Mon Nov 16 22:57:50 2009 +0000

    Rename protocolIsValid to isValidProtocol.
    https://bugs.webkit.org/show_bug.cgi?id=31503
    
    Reviewed by Darin Adler.
    
    This name change was suggested in https://bugs.webkit.org/show_bug.cgi?id=29972#c19.
    
    No new tests since no new functionality was introduced.
    
    * html/HTMLAnchorElement.cpp:
    (WebCore::HTMLAnchorElement::setProtocol):
    * platform/KURL.cpp:
    (WebCore::isValidProtocol):
    * platform/KURL.h:
    * platform/KURLGoogle.cpp:
    (WebCore::isValidProtocol):
    
    
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@51056 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
index 3686843..08284f6 100644
--- a/WebCore/ChangeLog
+++ b/WebCore/ChangeLog
@@ -1,3 +1,22 @@
+2009-11-16  Yael Aharon  <yael.aharon at nokia.com>
+
+        Reviewed by Darin Adler.
+
+        Rename protocolIsValid to isValidProtocol.
+        https://bugs.webkit.org/show_bug.cgi?id=31503
+
+        This name change was suggested in https://bugs.webkit.org/show_bug.cgi?id=29972#c19.
+
+        No new tests since no new functionality was introduced.
+
+        * html/HTMLAnchorElement.cpp:
+        (WebCore::HTMLAnchorElement::setProtocol):
+        * platform/KURL.cpp:
+        (WebCore::isValidProtocol):
+        * platform/KURL.h:
+        * platform/KURLGoogle.cpp:
+        (WebCore::isValidProtocol):
+
 2009-11-16  Chris Fleizach  <cfleizach at apple.com>
 
         Reviewed by Beth Dakin.
diff --git a/WebCore/html/HTMLAnchorElement.cpp b/WebCore/html/HTMLAnchorElement.cpp
index de473a2..1f71fcd 100644
--- a/WebCore/html/HTMLAnchorElement.cpp
+++ b/WebCore/html/HTMLAnchorElement.cpp
@@ -507,7 +507,7 @@ void HTMLAnchorElement::setProtocol(const String& value)
     KURL url = href();
     // Following Firefox 3.5.2 which removes anything after the first ":"
     String newProtocol = value.substring(0, separator);
-    if (!protocolIsValid(newProtocol))
+    if (!isValidProtocol(newProtocol))
         return;
     url.setProtocol(newProtocol);
 
diff --git a/WebCore/platform/KURL.cpp b/WebCore/platform/KURL.cpp
index 90c5b0f..3c93952 100644
--- a/WebCore/platform/KURL.cpp
+++ b/WebCore/platform/KURL.cpp
@@ -1628,7 +1628,7 @@ bool protocolIsJavaScript(const String& url)
     return protocolIs(url, "javascript");
 }
 
-bool protocolIsValid(const String& protocol)
+bool isValidProtocol(const String& protocol)
 {
     if (!isSchemeFirstChar(protocol[0]))
         return false;
diff --git a/WebCore/platform/KURL.h b/WebCore/platform/KURL.h
index 4833e08..993842e 100644
--- a/WebCore/platform/KURL.h
+++ b/WebCore/platform/KURL.h
@@ -262,7 +262,7 @@ const KURL& blankURL();
 
 bool protocolIs(const String& url, const char* protocol);
 bool protocolIsJavaScript(const String& url);
-bool protocolIsValid(const String& protocol);
+bool isValidProtocol(const String& protocol);
 
 String mimeTypeFromDataURL(const String& url);
 
diff --git a/WebCore/platform/KURLGoogle.cpp b/WebCore/platform/KURLGoogle.cpp
index 17b65fa..4336737 100644
--- a/WebCore/platform/KURLGoogle.cpp
+++ b/WebCore/platform/KURLGoogle.cpp
@@ -721,7 +721,7 @@ bool protocolIsJavaScript(const String& url)
     return protocolIs(url, "javascript");
 }
 
-bool protocolIsValid(const String& protocol)
+bool isValidProtocol(const String& protocol)
 {
     if (!isSchemeFirstChar(protocol[0]))
         return false;

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list