[SCM] WebKit Debian packaging branch, webkit-1.2, updated. upstream/1.1.90-6072-g9a69373

eric at webkit.org eric at webkit.org
Thu Apr 8 00:33:11 UTC 2010


The following commit has been merged in the webkit-1.2 branch:
commit 6949da7298cce748c21e870be104b17d9e874bd8
Author: eric at webkit.org <eric at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Fri Dec 11 20:50:47 2009 +0000

    2009-12-11  Adam Barth  <abarth at webkit.org>
    
            Reviewed by Eric Seidel.
    
            [check-webkit-style] False positive for tst_QWebFrame
            https://bugs.webkit.org/show_bug.cgi?id=32436
    
            Add an exception for function names that start with "tst_".  These are
            used by the Qt unit testing framework.
    
            * Scripts/modules/cpp_style.py:
            * Scripts/modules/cpp_style_unittest.py:
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@52016 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index 119d265..9625fb1 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,3 +1,16 @@
+2009-12-11  Adam Barth  <abarth at webkit.org>
+
+        Reviewed by Eric Seidel.
+
+        [check-webkit-style] False positive for tst_QWebFrame
+        https://bugs.webkit.org/show_bug.cgi?id=32436
+
+        Add an exception for function names that start with "tst_".  These are
+        used by the Qt unit testing framework.
+
+        * Scripts/modules/cpp_style.py:
+        * Scripts/modules/cpp_style_unittest.py:
+
 2009-12-11  Simon Hausmann  <hausmann at webkit.org>, Kim Grönholm  <kim.gronholm at nomovok.com>
 
         Reviewed by Antti Koivisto.
diff --git a/WebKitTools/Scripts/modules/cpp_style.py b/WebKitTools/Scripts/modules/cpp_style.py
index d8ca8d1..f268610 100644
--- a/WebKitTools/Scripts/modules/cpp_style.py
+++ b/WebKitTools/Scripts/modules/cpp_style.py
@@ -2737,6 +2737,7 @@ def check_identifier_name_in_declaration(filename, line_number, line, error):
         if modified_identifier.find('_') >= 0:
             # Various exceptions to the rule: JavaScript op codes functions, const_iterator.
             if (not (filename.find('JavaScriptCore') >= 0 and modified_identifier.find('_op_') >= 0)
+                and not modified_identifier.startswith('tst_')
                 and not modified_identifier == "const_iterator"):
                 error(filename, line_number, 'readability/naming', 4, identifier + " is incorrectly named. Don't use underscores in your identifier names.")
 
diff --git a/WebKitTools/Scripts/modules/cpp_style_unittest.py b/WebKitTools/Scripts/modules/cpp_style_unittest.py
index 75dd47e..41c888c 100644
--- a/WebKitTools/Scripts/modules/cpp_style_unittest.py
+++ b/WebKitTools/Scripts/modules/cpp_style_unittest.py
@@ -3703,6 +3703,9 @@ class WebKitStyleTest(CppStyleTestBase):
         self.assert_lint('void this_op_code(int var1, int var2)', '', 'JavaScriptCore/foo.cpp')
         self.assert_lint('void this_op_code(int var1, int var2)', 'this_op_code' + name_error_message)
 
+        # There is an exception for some unit tests that begin with "tst_".
+        self.assert_lint('void tst_QWebFrame::arrayObjectEnumerable(int var1, int var2)', '')
+
         # const_iterator is allowed as well.
         self.assert_lint('typedef VectorType::const_iterator const_iterator;', '')
 

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list