[SCM] WebKit Debian packaging branch, webkit-1.2, updated. upstream/1.1.90-6072-g9a69373

eric at webkit.org eric at webkit.org
Thu Apr 8 01:11:34 UTC 2010


The following commit has been merged in the webkit-1.2 branch:
commit 8bd450f1a29f941eb2f181eddc5a126ff64a9d61
Author: eric at webkit.org <eric at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Mon Jan 18 02:06:09 2010 +0000

    2010-01-17  Adam Barth  <abarth at webkit.org>
    
            Reviewed by Shinichiro Hamaji.
    
            check-webkit-style underscore check should be disabled for Qt methods starting with qt_
            https://bugs.webkit.org/show_bug.cgi?id=33663
    
            * Scripts/webkitpy/style/cpp_style.py:
            * Scripts/webkitpy/style/cpp_style_unittest.py:
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@53381 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index c26abb3..230d79b 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,5 +1,15 @@
 2010-01-17  Adam Barth  <abarth at webkit.org>
 
+        Reviewed by Shinichiro Hamaji.
+
+        check-webkit-style underscore check should be disabled for Qt methods starting with qt_
+        https://bugs.webkit.org/show_bug.cgi?id=33663
+
+        * Scripts/webkitpy/style/cpp_style.py:
+        * Scripts/webkitpy/style/cpp_style_unittest.py:
+
+2010-01-17  Adam Barth  <abarth at webkit.org>
+
         Reviewed by Eric Seidel.
 
         style-queue complains about missing #include of config.h for non-WebCore projects
diff --git a/WebKitTools/Scripts/webkitpy/style/cpp_style.py b/WebKitTools/Scripts/webkitpy/style/cpp_style.py
index a8a87d9..77c078d 100644
--- a/WebKitTools/Scripts/webkitpy/style/cpp_style.py
+++ b/WebKitTools/Scripts/webkitpy/style/cpp_style.py
@@ -2483,6 +2483,8 @@ def check_identifier_name_in_declaration(filename, line_number, line, error):
             # Various exceptions to the rule: JavaScript op codes functions, const_iterator.
             if (not (filename.find('JavaScriptCore') >= 0 and modified_identifier.find('_op_') >= 0)
                 and not modified_identifier.startswith('tst_')
+                and not modified_identifier.startswith('qt_')
+                and not modified_identifier.find('::qt_') >= 0
                 and not modified_identifier == "const_iterator"):
                 error(filename, line_number, 'readability/naming', 4, identifier + " is incorrectly named. Don't use underscores in your identifier names.")
 
diff --git a/WebKitTools/Scripts/webkitpy/style/cpp_style_unittest.py b/WebKitTools/Scripts/webkitpy/style/cpp_style_unittest.py
index a9edec2..a20048e 100644
--- a/WebKitTools/Scripts/webkitpy/style/cpp_style_unittest.py
+++ b/WebKitTools/Scripts/webkitpy/style/cpp_style_unittest.py
@@ -3542,6 +3542,10 @@ class WebKitStyleTest(CppStyleTestBase):
         # There is an exception for some unit tests that begin with "tst_".
         self.assert_lint('void tst_QWebFrame::arrayObjectEnumerable(int var1, int var2)', '')
 
+        # The Qt API uses names that begin with "qt_".
+        self.assert_lint('void QTFrame::qt_drt_is_awesome(int var1, int var2)', '')
+        self.assert_lint('void qt_drt_is_awesome(int var1, int var2);', '')
+
         # const_iterator is allowed as well.
         self.assert_lint('typedef VectorType::const_iterator const_iterator;', '')
 

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list