[SCM] WebKit Debian packaging branch, debian/experimental, updated. upstream/1.3.3-9427-gc2be6fc

commit-queue at webkit.org commit-queue at webkit.org
Wed Dec 22 15:47:05 UTC 2010


The following commit has been merged in the debian/experimental branch:
commit 21c662acce193aefa3200bde45e5866b439042c4
Author: commit-queue at webkit.org <commit-queue at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Fri Nov 12 07:21:14 2010 +0000

    2010-11-11  Ademar de Souza Reis Jr  <ademar.reis at openbossa.org>
    
            Reviewed by Shinichiro Hamaji.
    
            Enable check-webkit-style on Qt files
            https://bugs.webkit.org/show_bug.cgi?id=48322
    
            Adding exception for _q_... private slots and
            ..._data() methods in tests
    
            * Scripts/webkitpy/style/checker.py: enable Qt dirs, add exceptions
            * Scripts/webkitpy/style/checker_unittest.py: improve unittests
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@71894 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index f3405ca..ae8eb27 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,3 +1,16 @@
+2010-11-11  Ademar de Souza Reis Jr  <ademar.reis at openbossa.org>
+
+        Reviewed by Shinichiro Hamaji.
+
+        Enable check-webkit-style on Qt files
+        https://bugs.webkit.org/show_bug.cgi?id=48322
+
+        Adding exception for _q_... private slots and
+        ..._data() methods in tests
+
+        * Scripts/webkitpy/style/checker.py: enable Qt dirs, add exceptions
+        * Scripts/webkitpy/style/checker_unittest.py: improve unittests
+
 2010-11-11  David Levin  <levin at chromium.org>
 
         Reviewed by Shinichiro Hamaji.
diff --git a/WebKitTools/Scripts/webkitpy/style/checker.py b/WebKitTools/Scripts/webkitpy/style/checker.py
index fb93eb9..e10eec5 100644
--- a/WebKitTools/Scripts/webkitpy/style/checker.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker.py
@@ -131,11 +131,13 @@ _PATH_RULES_SPECIFIER = [
       "WebKit/efl/ewk/",
       # There is no clean way to avoid "yy_*" names used by flex.
       "WebCore/css/CSSParser.cpp",
-      # There is no clean way to avoid "xxx_data" methods inside
-      # Qt's autotests since they are called automatically by the
-      # QtTest module.
+      # Qt code uses '_' in some places (such as private slots
+      # and on test xxx_data methos on tests)
+      "JavaScriptCore/qt/api/",
+      "WebKit/qt/Api/",
       "WebKit/qt/tests/",
-      "JavaScriptCore/qt/tests"],
+      "WebKit/qt/declarative/",
+      "WebKit/qt/examples/"],
      ["-readability/naming"]),
     ([# The GTK+ APIs use GTK+ naming style, which includes
       # lower-cased, underscore-separated values.
@@ -232,15 +234,9 @@ _TEXT_FILE_EXTENSIONS = [
 # WebKit maintains some files in Mozilla style on purpose to ease
 # future merges.
 _SKIPPED_FILES_WITH_WARNING = [
-    # The Qt API and tests do not follow WebKit style.
-    # They follow Qt style. :)
     "gtk2drawing.c", # WebCore/platform/gtk/gtk2drawing.c
     "gtkdrawing.h", # WebCore/platform/gtk/gtkdrawing.h
-    "JavaScriptCore/qt/api/",
     "WebKit/gtk/tests/",
-    "WebKit/qt/Api/",
-    "WebKit/qt/tests/",
-    "WebKit/qt/examples/",
     # Soup API that is still being cooked, will be removed from WebKit
     # in a few months when it is merged into soup proper. The style
     # follows the libsoup style completely.
diff --git a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
index 43d24fe..94d2c29 100755
--- a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
@@ -223,11 +223,29 @@ class GlobalVariablesTest(unittest.TestCase):
                       "readability/naming")
         assertNoCheck("WebCore/css/CSSParser.cpp",
                       "readability/naming")
+
+        # Test if Qt exceptions are indeed working
+        assertCheck("JavaScriptCore/qt/api/qscriptengine.cpp",
+                    "readability/braces")
+        assertCheck("WebKit/qt/Api/qwebpage.cpp",
+                    "readability/braces")
+        assertCheck("WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
+                    "readability/braces")
+        assertCheck("WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
+                    "readability/braces")
+        assertCheck("WebKit/qt/examples/platformplugin/WebPlugin.cpp",
+                    "readability/braces")
+        assertNoCheck("JavaScriptCore/qt/api/qscriptengine.cpp",
+                      "readability/naming")
+        assertNoCheck("WebKit/qt/Api/qwebpage.cpp",
+                      "readability/naming")
         assertNoCheck("WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
                       "readability/naming")
-        assertNoCheck(
-            "JavaScriptCore/qt/tests/qscriptengine/tst_qscriptengine.cpp",
-            "readability/naming")
+        assertNoCheck("WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
+                      "readability/naming")
+        assertNoCheck("WebKit/qt/examples/platformplugin/WebPlugin.cpp",
+                      "readability/naming")
+
         assertNoCheck("WebCore/ForwardingHeaders/debugger/Debugger.h",
                       "build/header_guard")
 
@@ -277,12 +295,9 @@ class CheckerDispatcherSkipTest(unittest.TestCase):
         paths_to_skip = [
            "gtk2drawing.c",
            "gtkdrawing.h",
-           "JavaScriptCore/qt/api/qscriptengine_p.h",
            "WebCore/platform/gtk/gtk2drawing.c",
            "WebCore/platform/gtk/gtkdrawing.h",
            "WebKit/gtk/tests/testatk.c",
-           "WebKit/qt/Api/qwebpage.h",
-           "WebKit/qt/tests/qwebsecurityorigin/tst_qwebsecurityorigin.cpp",
             ]
 
         for path in paths_to_skip:

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list