[SCM] WebKit Debian packaging branch, debian/experimental, updated. upstream/1.3.3-9427-gc2be6fc

mrobinson at webkit.org mrobinson at webkit.org
Wed Dec 22 13:30:31 UTC 2010


The following commit has been merged in the debian/experimental branch:
commit e9c212d523b4bbf7de9ad30abae219fc75a4e4fb
Author: mrobinson at webkit.org <mrobinson at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Fri Sep 17 17:20:13 2010 +0000

    2010-09-17  Martin Robinson  <mrobinson at igalia.com>
    
            Reviewed by Oliver Hunt.
    
            Style bot complains about cairo forward declaration naming
            https://bugs.webkit.org/show_bug.cgi?id=45867
    
            Exclude Cairo forward declarations from indentifiers with underscores checks.
    
            * Scripts/webkitpy/style/checkers/cpp.py: Add exclusion for Cairo forward-declarations.
            * Scripts/webkitpy/style/checkers/cpp_unittest.py: Add some tests for this.
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@67722 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index 55027d2..97a9a8b 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,3 +1,15 @@
+2010-09-17  Martin Robinson  <mrobinson at igalia.com>
+
+        Reviewed by Oliver Hunt.
+
+        Style bot complains about cairo forward declaration naming
+        https://bugs.webkit.org/show_bug.cgi?id=45867
+
+        Exclude Cairo forward declarations from indentifiers with underscores checks.
+
+        * Scripts/webkitpy/style/checkers/cpp.py: Add exclusion for Cairo forward-declarations.
+        * Scripts/webkitpy/style/checkers/cpp_unittest.py: Add some tests for this.
+
 2010-09-16  Kinuko Yasuda  <kinuko at chromium.org>
 
         Reviewed by Ojan Vafai.
diff --git a/WebKitTools/Scripts/webkitpy/style/checkers/cpp.py b/WebKitTools/Scripts/webkitpy/style/checkers/cpp.py
index 62f40ea..f8ebeff 100644
--- a/WebKitTools/Scripts/webkitpy/style/checkers/cpp.py
+++ b/WebKitTools/Scripts/webkitpy/style/checkers/cpp.py
@@ -2519,6 +2519,7 @@ def check_identifier_name_in_declaration(filename, line_number, line, error):
                 and not modified_identifier.startswith('NPP_')
                 and not modified_identifier.startswith('NP_')
                 and not modified_identifier.startswith('qt_')
+                and not modified_identifier.startswith('cairo_')
                 and not modified_identifier.find('::qt_') >= 0
                 and not modified_identifier == "const_iterator"):
                 error(line_number, 'readability/naming', 4, identifier + " is incorrectly named. Don't use underscores in your identifier names.")
diff --git a/WebKitTools/Scripts/webkitpy/style/checkers/cpp_unittest.py b/WebKitTools/Scripts/webkitpy/style/checkers/cpp_unittest.py
index 16b1a3c..2f54305 100644
--- a/WebKitTools/Scripts/webkitpy/style/checkers/cpp_unittest.py
+++ b/WebKitTools/Scripts/webkitpy/style/checkers/cpp_unittest.py
@@ -3703,6 +3703,11 @@ class WebKitStyleTest(CppStyleTestBase):
         self.assert_lint('void QTFrame::qt_drt_is_awesome(int var1, int var2)', '')
         self.assert_lint('void qt_drt_is_awesome(int var1, int var2);', '')
 
+        # Cairo forward-declarations should not be a failure.
+        self.assert_lint('typedef struct _cairo cairo_t;', '')
+        self.assert_lint('typedef struct _cairo_surface cairo_surface_t;', '')
+        self.assert_lint('typedef struct _cairo_scaled_font cairo_scaled_font_t;', '')
+
         # NPAPI functions that start with NPN_, NPP_ or NP_ are allowed.
         self.assert_lint('void NPN_Status(NPP, const char*)', '')
         self.assert_lint('NPError NPP_SetWindow(NPP instance, NPWindow *window)', '')

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list