[SCM] WebKit Debian packaging branch, debian/experimental, updated. upstream/1.3.3-9427-gc2be6fc

abarth at webkit.org abarth at webkit.org
Wed Dec 22 15:32:54 UTC 2010


The following commit has been merged in the debian/experimental branch:
commit 45077e121f74e615d7eee5a5ea144c18b4911b36
Author: abarth at webkit.org <abarth at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Mon Nov 8 04:44:51 2010 +0000

    2010-11-07  Adam Barth  <abarth at webkit.org>
    
            Reviewed by Eric Seidel.
    
            Rename X-Purpose to Purpose
            https://bugs.webkit.org/show_bug.cgi?id=47802
    
            As requested by IETF HTTP WG.  This patch is part of a larger movement
            in the HTTP community to move away from X- headers.  Various senior
            folks at the IETF believe they're a failed experiment:
    
            http://tools.ietf.org/html/draft-saintandre-xdash-considered-harmful
    
            * loader/loader.cpp:
            (WebCore::Loader::Host::servePendingRequests):
    2010-11-07  Adam Barth  <abarth at webkit.org>
    
            Reviewed by Eric Seidel.
    
            Rename X-Purpose to Purpose
            https://bugs.webkit.org/show_bug.cgi?id=47802
    
            Update expected results.
    
            * http/tests/misc/prefetch-purpose-expected.txt:
            * http/tests/misc/resources/prefetch-purpose.php:
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@71494 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/LayoutTests/ChangeLog b/LayoutTests/ChangeLog
index 9c9fead..b4b1d94 100644
--- a/LayoutTests/ChangeLog
+++ b/LayoutTests/ChangeLog
@@ -1,3 +1,15 @@
+2010-11-07  Adam Barth  <abarth at webkit.org>
+
+        Reviewed by Eric Seidel.
+
+        Rename X-Purpose to Purpose
+        https://bugs.webkit.org/show_bug.cgi?id=47802
+
+        Update expected results.
+
+        * http/tests/misc/prefetch-purpose-expected.txt:
+        * http/tests/misc/resources/prefetch-purpose.php:
+
 2010-11-05  Helder Correia  <helder at sencha.com>
 
         Reviewed by Andreas Kling.
diff --git a/LayoutTests/http/tests/misc/prefetch-purpose-expected.txt b/LayoutTests/http/tests/misc/prefetch-purpose-expected.txt
index 68486ea..52acec5 100644
--- a/LayoutTests/http/tests/misc/prefetch-purpose-expected.txt
+++ b/LayoutTests/http/tests/misc/prefetch-purpose-expected.txt
@@ -2,6 +2,6 @@ prefetch-purpose.php has MIME type text/html
 prefetch-purpose.php has MIME type text/html
 The cookie was set!
 
-X-Purpose: prefetch
+Purpose: prefetch
 
-This test verifies that prefetches are sent with the HTTP request header X-Purpose: prefetch. To do this, the root page has a prefetch link targetting this subresource which contains a PHP script (resources/prefetch-purpose.php). That initial prefetch of this resource sets a cookie. Later, the root page sets window.location to target this script, which verifies the presence of the cookie, and generates the happy test output that you hopefully see right now.
+This test verifies that prefetches are sent with the HTTP request header Purpose: prefetch. To do this, the root page has a prefetch link targetting this subresource which contains a PHP script (resources/prefetch-purpose.php). That initial prefetch of this resource sets a cookie. Later, the root page sets window.location to target this script, which verifies the presence of the cookie, and generates the happy test output that you hopefully see right now.
diff --git a/LayoutTests/http/tests/misc/resources/prefetch-purpose.php b/LayoutTests/http/tests/misc/resources/prefetch-purpose.php
index 9693eb9..cad3320 100644
--- a/LayoutTests/http/tests/misc/resources/prefetch-purpose.php
+++ b/LayoutTests/http/tests/misc/resources/prefetch-purpose.php
@@ -1,10 +1,10 @@
-<?php setcookie("X-Purpose", $_SERVER["HTTP_X_PURPOSE"]);
+<?php setcookie("Purpose", $_SERVER["HTTP_X_PURPOSE"]);
 
-if (isset($_COOKIE['X-Purpose'])) {
-    setcookie("X-Purpose", "", time() - 3600);
+if (isset($_COOKIE['Purpose'])) {
+    setcookie("Purpose", "", time() - 3600);
     echo "<h1>The cookie was set!</h1>";
-    echo "<p>X-Purpose: ";
-    echo $_COOKIE['X-Purpose'];
+    echo "<p>Purpose: ";
+    echo $_COOKIE['Purpose'];
 } else {
     echo "<h1>BAD BROWSER NO COOKIE</h1>";
 }
@@ -15,7 +15,7 @@ layoutTestController.notifyDone();
 </script>
 
 <p>This test verifies that prefetches are sent with the HTTP request header
-<b>X-Purpose: prefetch</b>.  To do this, the root page has a prefetch
+<b>Purpose: prefetch</b>.  To do this, the root page has a prefetch
 link targetting this subresource which contains a PHP script
 (resources/prefetch-purpose.php).  That initial prefetch of this
 resource sets a cookie.  Later, the root page sets window.location to
diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
index 4775b08..ba0bc01 100644
--- a/WebCore/ChangeLog
+++ b/WebCore/ChangeLog
@@ -1,3 +1,19 @@
+2010-11-07  Adam Barth  <abarth at webkit.org>
+
+        Reviewed by Eric Seidel.
+
+        Rename X-Purpose to Purpose
+        https://bugs.webkit.org/show_bug.cgi?id=47802
+
+        As requested by IETF HTTP WG.  This patch is part of a larger movement
+        in the HTTP community to move away from X- headers.  Various senior
+        folks at the IETF believe they're a failed experiment:
+
+        http://tools.ietf.org/html/draft-saintandre-xdash-considered-harmful
+
+        * loader/loader.cpp:
+        (WebCore::Loader::Host::servePendingRequests):
+
 2010-11-07  Daniel Bates  <dbates at rim.com>
 
         Reviewed by Adam Barth.
diff --git a/WebCore/loader/loader.cpp b/WebCore/loader/loader.cpp
index aa3f246..655ff92 100644
--- a/WebCore/loader/loader.cpp
+++ b/WebCore/loader/loader.cpp
@@ -368,7 +368,7 @@ void Loader::Host::servePendingRequests(RequestQueue& requestsPending, bool& ser
 
 #if ENABLE(LINK_PREFETCH)
         if (request->cachedResource()->type() == CachedResource::LinkPrefetch)
-            resourceRequest.setHTTPHeaderField("X-Purpose", "prefetch");
+            resourceRequest.setHTTPHeaderField("Purpose", "prefetch");
 #endif
 
         RefPtr<SubresourceLoader> loader = SubresourceLoader::create(cachedResourceLoader->doc()->frame(),

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list