[SCM] WebKit Debian packaging branch, webkit-1.1, updated. upstream/1.1.21-584-g1e41756
eric at webkit.org
eric at webkit.org
Fri Feb 26 22:26:11 UTC 2010
The following commit has been merged in the webkit-1.1 branch:
commit cd53859c2ddde77bfd5ec38f75be9e7f96ef80db
Author: eric at webkit.org <eric at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Sat Feb 20 02:08:39 2010 +0000
2010-02-19 Leandro Pereira <leandro at profusion.mobi>
Reviewed by Shinichiro Hamaji.
[style-queue] should not complain about identifier names with underscores under WebKit/efl/ewk/
https://bugs.webkit.org/show_bug.cgi?id=35091
White list unix_hacker_style names in WebKit/efl/ewk because these
are used in the EFL API.
* Scripts/webkitpy/style/checker.py:
- Filter out readability/naming on WebKit/efl/ewk.
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@55042 268f45cc-cd09-0410-ab3c-d52691b4dbfc
diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index 0fb5cbc..632bb37 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,3 +1,16 @@
+2010-02-19 Leandro Pereira <leandro at profusion.mobi>
+
+ Reviewed by Shinichiro Hamaji.
+
+ [style-queue] should not complain about identifier names with underscores under WebKit/efl/ewk/
+ https://bugs.webkit.org/show_bug.cgi?id=35091
+
+ White list unix_hacker_style names in WebKit/efl/ewk because these
+ are used in the EFL API.
+
+ * Scripts/webkitpy/style/checker.py:
+ - Filter out readability/naming on WebKit/efl/ewk.
+
2010-02-19 Eric Seidel <eric at webkit.org>
Reviewed by Adam Barth.
diff --git a/WebKitTools/Scripts/webkitpy/style/checker.py b/WebKitTools/Scripts/webkitpy/style/checker.py
index 9beda9e..5d36183 100644
--- a/WebKitTools/Scripts/webkitpy/style/checker.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker.py
@@ -109,6 +109,10 @@ _PATH_RULES_SPECIFIER = [
([# The GTK+ APIs use GTK+ naming style, which includes
# lower-cased, underscore-separated values.
"WebKit/gtk/webkit/",
+ # The EFL APIs use EFL naming style, which includes
+ # both lower-cased and camel-cased, underscore-sparated
+ # values.
+ "WebKit/efl/ewk/",
# There is no clean way to avoid "yy_*" names used by flex.
"WebCore/css/CSSParser.cpp",
# There is no clean way to avoid "xxx_data" methods inside
diff --git a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
index fe12512..f8b3a3a 100755
--- a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
@@ -125,6 +125,8 @@ class GlobalVariablesTest(unittest.TestCase):
"readability/naming")
assertNoCheck("WebKit/gtk/webkit/webkit.h",
"readability/naming")
+ assertNoCheck("WebKit/efl/ewk/ewk_view.h",
+ "readability/naming")
assertNoCheck("WebCore/css/CSSParser.cpp",
"readability/naming")
assertNoCheck("WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
--
WebKit Debian packaging
More information about the Pkg-webkit-commits
mailing list