[SCM] WebKit Debian packaging branch, webkit-1.1, updated. upstream/1.1.22-985-g3c00f00
hamaji at chromium.org
hamaji at chromium.org
Wed Mar 17 17:56:39 UTC 2010
The following commit has been merged in the webkit-1.1 branch:
commit 1e970c1aac18bc6ab4b4c1d14eb774cd823fa196
Author: hamaji at chromium.org <hamaji at chromium.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Tue Feb 23 06:28:32 2010 +0000
2010-02-22 Shinichiro Hamaji <hamaji at chromium.org>
Reviewed by David Levin.
[Gtk] check-webkit-style: GTK style should be allowed in WebKitTools/DumpRenderTree/gtk
https://bugs.webkit.org/show_bug.cgi?id=35229
* Scripts/webkitpy/style/checker.py:
* Scripts/webkitpy/style/checker_unittest.py:
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@55121 268f45cc-cd09-0410-ab3c-d52691b4dbfc
diff --git a/WebKitTools/ChangeLog b/WebKitTools/ChangeLog
index 4dd6faa..9c410c2 100644
--- a/WebKitTools/ChangeLog
+++ b/WebKitTools/ChangeLog
@@ -1,3 +1,13 @@
+2010-02-22 Shinichiro Hamaji <hamaji at chromium.org>
+
+ Reviewed by David Levin.
+
+ [Gtk] check-webkit-style: GTK style should be allowed in WebKitTools/DumpRenderTree/gtk
+ https://bugs.webkit.org/show_bug.cgi?id=35229
+
+ * Scripts/webkitpy/style/checker.py:
+ * Scripts/webkitpy/style/checker_unittest.py:
+
2010-02-22 James Robinson <jamesr at chromium.org>
Unreviewed. Adding myself to committers list.
diff --git a/WebKitTools/Scripts/webkitpy/style/checker.py b/WebKitTools/Scripts/webkitpy/style/checker.py
index 5d36183..32cded3 100644
--- a/WebKitTools/Scripts/webkitpy/style/checker.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker.py
@@ -106,10 +106,7 @@ _PATH_RULES_SPECIFIER = [
"WebKit/qt/QGVLauncher/"],
["-build/include",
"-readability/streams"]),
- ([# The GTK+ APIs use GTK+ naming style, which includes
- # lower-cased, underscore-separated values.
- "WebKit/gtk/webkit/",
- # The EFL APIs use EFL naming style, which includes
+ ([# The EFL APIs use EFL naming style, which includes
# both lower-cased and camel-cased, underscore-sparated
# values.
"WebKit/efl/ewk/",
@@ -121,6 +118,13 @@ _PATH_RULES_SPECIFIER = [
"WebKit/qt/tests/",
"JavaScriptCore/qt/tests"],
["-readability/naming"]),
+ ([# The GTK+ APIs use GTK+ naming style, which includes
+ # lower-cased, underscore-separated values.
+ # Also, GTK+ allows the use of NULL.
+ "WebKit/gtk/webkit/",
+ "WebKitTools/DumpRenderTree/gtk/"],
+ ["-readability/naming",
+ "-readability/null"]),
]
diff --git a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
index f8b3a3a..cdd2ac4 100755
--- a/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
+++ b/WebKitTools/Scripts/webkitpy/style/checker_unittest.py
@@ -125,6 +125,8 @@ class GlobalVariablesTest(unittest.TestCase):
"readability/naming")
assertNoCheck("WebKit/gtk/webkit/webkit.h",
"readability/naming")
+ assertNoCheck("WebKitTools/DumpRenderTree/gtk/DumpRenderTree.cpp",
+ "readability/null")
assertNoCheck("WebKit/efl/ewk/ewk_view.h",
"readability/naming")
assertNoCheck("WebCore/css/CSSParser.cpp",
--
WebKit Debian packaging
More information about the Pkg-webkit-commits
mailing list