[SCM] WebKit Debian packaging branch, webkit-1.3, updated. upstream/1.3.7-4207-g178b198

commit-queue at webkit.org commit-queue at webkit.org
Sun Feb 20 23:44:08 UTC 2011


The following commit has been merged in the webkit-1.3 branch:
commit a91fd12557835985dc1736ec53f2868466c023e8
Author: commit-queue at webkit.org <commit-queue at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Mon Jan 24 18:33:04 2011 +0000

    2011-01-24  Andreas Kling  <kling at webkit.org>
    
            Reviewed by Darin Adler.
    
            check-webkit-style: Update exemptions following Source/ move.
            https://bugs.webkit.org/show_bug.cgi?id=53017
    
            * Scripts/webkitpy/style/checker.py:
            * Scripts/webkitpy/style/checker_unittest.py:
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@76530 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/Tools/ChangeLog b/Tools/ChangeLog
index d41e033..20b0539 100644
--- a/Tools/ChangeLog
+++ b/Tools/ChangeLog
@@ -1,3 +1,13 @@
+2011-01-24  Andreas Kling  <kling at webkit.org>
+
+        Reviewed by Darin Adler.
+
+        check-webkit-style: Update exemptions following Source/ move.
+        https://bugs.webkit.org/show_bug.cgi?id=53017
+
+        * Scripts/webkitpy/style/checker.py:
+        * Scripts/webkitpy/style/checker_unittest.py:
+
 2011-01-24  Andras Becsi  <abecsi at webkit.org>
 
         Rubber-stamped by Csaba Osztrogonác.
diff --git a/Tools/Scripts/webkitpy/style/checker.py b/Tools/Scripts/webkitpy/style/checker.py
index ebcf326..3b16c1f 100644
--- a/Tools/Scripts/webkitpy/style/checker.py
+++ b/Tools/Scripts/webkitpy/style/checker.py
@@ -129,16 +129,16 @@ _PATH_RULES_SPECIFIER = [
     ([# The EFL APIs use EFL naming style, which includes
       # both lower-cased and camel-cased, underscore-sparated
       # values.
-      "WebKit/efl/ewk/",
+      "Source/WebKit/efl/ewk/",
       # There is no clean way to avoid "yy_*" names used by flex.
       "Source/WebCore/css/CSSParser.cpp",
       # Qt code uses '_' in some places (such as private slots
       # and on test xxx_data methos on tests)
       "Source/JavaScriptCore/qt/",
-      "WebKit/qt/Api/",
-      "WebKit/qt/tests/",
-      "WebKit/qt/declarative/",
-      "WebKit/qt/examples/"],
+      "Source/WebKit/qt/Api/",
+      "Source/WebKit/qt/tests/",
+      "Source/WebKit/qt/declarative/",
+      "Source/WebKit/qt/examples/"],
      ["-readability/naming"]),
     ([# The GTK+ APIs use GTK+ naming style, which includes
       # lower-cased, underscore-separated values.
@@ -243,7 +243,7 @@ _XML_FILE_EXTENSIONS = [
 _SKIPPED_FILES_WITH_WARNING = [
     "gtk2drawing.c", # WebCore/platform/gtk/gtk2drawing.c
     "gtkdrawing.h", # WebCore/platform/gtk/gtkdrawing.h
-    "WebKit/gtk/tests/",
+    "Source/WebKit/gtk/tests/",
     # Soup API that is still being cooked, will be removed from WebKit
     # in a few months when it is merged into soup proper. The style
     # follows the libsoup style completely.
diff --git a/Tools/Scripts/webkitpy/style/checker_unittest.py b/Tools/Scripts/webkitpy/style/checker_unittest.py
index a4649d2..31d59af 100755
--- a/Tools/Scripts/webkitpy/style/checker_unittest.py
+++ b/Tools/Scripts/webkitpy/style/checker_unittest.py
@@ -216,11 +216,11 @@ class GlobalVariablesTest(unittest.TestCase):
                       "build/include")
         assertCheck("random_path.cpp",
                     "readability/naming")
-        assertNoCheck("WebKit/gtk/webkit/webkit.h",
+        assertNoCheck("Source/WebKit/gtk/webkit/webkit.h",
                       "readability/naming")
         assertNoCheck("Tools/DumpRenderTree/gtk/DumpRenderTree.cpp",
                       "readability/null")
-        assertNoCheck("WebKit/efl/ewk/ewk_view.h",
+        assertNoCheck("Source/WebKit/efl/ewk/ewk_view.h",
                       "readability/naming")
         assertNoCheck("Source/WebCore/css/CSSParser.cpp",
                       "readability/naming")
@@ -228,26 +228,26 @@ class GlobalVariablesTest(unittest.TestCase):
         # Test if Qt exceptions are indeed working
         assertCheck("Source/JavaScriptCore/qt/api/qscriptengine.cpp",
                     "readability/braces")
-        assertCheck("WebKit/qt/Api/qwebpage.cpp",
+        assertCheck("Source/WebKit/qt/Api/qwebpage.cpp",
                     "readability/braces")
-        assertCheck("WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
+        assertCheck("Source/WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
                     "readability/braces")
-        assertCheck("WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
+        assertCheck("Source/WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
                     "readability/braces")
-        assertCheck("WebKit/qt/examples/platformplugin/WebPlugin.cpp",
+        assertCheck("Source/WebKit/qt/examples/platformplugin/WebPlugin.cpp",
                     "readability/braces")
         assertNoCheck("Source/JavaScriptCore/qt/api/qscriptengine.cpp",
                       "readability/naming")
         assertNoCheck("Source/JavaScriptCore/qt/benchmarks"
                       "/qscriptengine/tst_qscriptengine.cpp",
                       "readability/naming")
-        assertNoCheck("WebKit/qt/Api/qwebpage.cpp",
+        assertNoCheck("Source/WebKit/qt/Api/qwebpage.cpp",
                       "readability/naming")
-        assertNoCheck("WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
+        assertNoCheck("Source/WebKit/qt/tests/qwebelement/tst_qwebelement.cpp",
                       "readability/naming")
-        assertNoCheck("WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
+        assertNoCheck("Source/WebKit/qt/declarative/platformplugin/WebPlugin.cpp",
                       "readability/naming")
-        assertNoCheck("WebKit/qt/examples/platformplugin/WebPlugin.cpp",
+        assertNoCheck("Source/WebKit/qt/examples/platformplugin/WebPlugin.cpp",
                       "readability/naming")
 
         assertNoCheck("Source/WebCore/ForwardingHeaders/debugger/Debugger.h",
@@ -301,7 +301,7 @@ class CheckerDispatcherSkipTest(unittest.TestCase):
            "gtkdrawing.h",
            "Source/WebCore/platform/gtk/gtk2drawing.c",
            "Source/WebCore/platform/gtk/gtkdrawing.h",
-           "WebKit/gtk/tests/testatk.c",
+           "Source/WebKit/gtk/tests/testatk.c",
             ]
 
         for path in paths_to_skip:

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list