[SCM] WebKit Debian packaging branch, debian/experimental, updated. debian/1.3.8-1-1049-g2e11a8e

dbates at webkit.org dbates at webkit.org
Fri Jan 21 14:43:50 UTC 2011


The following commit has been merged in the debian/experimental branch:
commit 77185cef5dcb3c8cdcfc18023b6103e30d313ee6
Author: dbates at webkit.org <dbates at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Tue Dec 28 00:21:23 2010 +0000

    2010-12-27  Daniel Bates  <dbates at rim.com>
    
            Reviewed by Antonio Gomes.
    
            Clean up: Rename HTMLFrameElementBase::getMarginWidth() and HTMLFrameElementBase::getMarginHeight()
            https://bugs.webkit.org/show_bug.cgi?id=51634
    
            Rename HTMLFrameElementBase::getMarginWidth() and HTMLFrameElementBase::getMarginHeight()
            to HTMLFrameElementBase::marginHeight() and HTMLFrameElementBase::marginHeight(), respectively.
            This will make the names of these getters consistent with the naming convention we use for
            getters.
    
            * html/HTMLBodyElement.cpp:
            (WebCore::HTMLBodyElement::insertedIntoDocument):
            * html/HTMLFrameElementBase.h:
            (WebCore::HTMLFrameElementBase::marginWidth): Renamed; Formerly getMarginWidth().
            (WebCore::HTMLFrameElementBase::marginHeight): Renamed; Formerly getMarginHeight().
            * loader/SubframeLoader.cpp:
            (WebCore::SubframeLoader::loadSubframe):
            * page/FrameView.cpp:
            (WebCore::FrameView::init):
            * rendering/RenderEmbeddedObject.cpp:
            (WebCore::RenderEmbeddedObject::viewCleared): Also renamed variables marginw and marginh
            to marginWidth and marginHeight, respectively. This makes the names of these variables
            consistent with the names of similar variables in SubframeLoader::loadSubframe() and FrameView::init().
            * rendering/RenderFrame.cpp:
            (WebCore::RenderFrame::viewCleared): Ditto.
    
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@74700 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
index a05ddd0..cf40297 100644
--- a/WebCore/ChangeLog
+++ b/WebCore/ChangeLog
@@ -1,3 +1,31 @@
+2010-12-27  Daniel Bates  <dbates at rim.com>
+
+        Reviewed by Antonio Gomes.
+
+        Clean up: Rename HTMLFrameElementBase::getMarginWidth() and HTMLFrameElementBase::getMarginHeight()
+        https://bugs.webkit.org/show_bug.cgi?id=51634
+
+        Rename HTMLFrameElementBase::getMarginWidth() and HTMLFrameElementBase::getMarginHeight()
+        to HTMLFrameElementBase::marginHeight() and HTMLFrameElementBase::marginHeight(), respectively.
+        This will make the names of these getters consistent with the naming convention we use for
+        getters.
+
+        * html/HTMLBodyElement.cpp:
+        (WebCore::HTMLBodyElement::insertedIntoDocument):
+        * html/HTMLFrameElementBase.h:
+        (WebCore::HTMLFrameElementBase::marginWidth): Renamed; Formerly getMarginWidth().
+        (WebCore::HTMLFrameElementBase::marginHeight): Renamed; Formerly getMarginHeight().
+        * loader/SubframeLoader.cpp:
+        (WebCore::SubframeLoader::loadSubframe):
+        * page/FrameView.cpp:
+        (WebCore::FrameView::init):
+        * rendering/RenderEmbeddedObject.cpp:
+        (WebCore::RenderEmbeddedObject::viewCleared): Also renamed variables marginw and marginh
+        to marginWidth and marginHeight, respectively. This makes the names of these variables
+        consistent with the names of similar variables in SubframeLoader::loadSubframe() and FrameView::init().
+        * rendering/RenderFrame.cpp:
+        (WebCore::RenderFrame::viewCleared): Ditto.
+
 2010-12-27  Martin Robinson  <mrobinson at igalia.com>
 
         Reviewed by Daniel Bates.
diff --git a/WebCore/html/HTMLBodyElement.cpp b/WebCore/html/HTMLBodyElement.cpp
index ac96741..88e2bdf 100644
--- a/WebCore/html/HTMLBodyElement.cpp
+++ b/WebCore/html/HTMLBodyElement.cpp
@@ -184,10 +184,10 @@ void HTMLBodyElement::insertedIntoDocument()
     Element* ownerElement = document()->ownerElement();
     if (ownerElement && (ownerElement->hasTagName(frameTag) || ownerElement->hasTagName(iframeTag))) {
         HTMLFrameElementBase* ownerFrameElement = static_cast<HTMLFrameElementBase*>(ownerElement);
-        int marginWidth = ownerFrameElement->getMarginWidth();
+        int marginWidth = ownerFrameElement->marginWidth();
         if (marginWidth != -1)
             setAttribute(marginwidthAttr, String::number(marginWidth));
-        int marginHeight = ownerFrameElement->getMarginHeight();
+        int marginHeight = ownerFrameElement->marginHeight();
         if (marginHeight != -1)
             setAttribute(marginheightAttr, String::number(marginHeight));
     }
diff --git a/WebCore/html/HTMLFrameElementBase.h b/WebCore/html/HTMLFrameElementBase.h
index 8770af5..e5f9c46 100644
--- a/WebCore/html/HTMLFrameElementBase.h
+++ b/WebCore/html/HTMLFrameElementBase.h
@@ -36,8 +36,8 @@ public:
 
     virtual ScrollbarMode scrollingMode() const { return m_scrolling; }
     
-    int getMarginWidth() const { return m_marginWidth; }
-    int getMarginHeight() const { return m_marginHeight; }
+    int marginWidth() const { return m_marginWidth; }
+    int marginHeight() const { return m_marginHeight; }
 
     int width() const;
     int height() const;
diff --git a/WebCore/loader/SubframeLoader.cpp b/WebCore/loader/SubframeLoader.cpp
index dd2b8de..eba3173 100644
--- a/WebCore/loader/SubframeLoader.cpp
+++ b/WebCore/loader/SubframeLoader.cpp
@@ -253,8 +253,8 @@ Frame* SubframeLoader::loadSubframe(HTMLFrameOwnerElement* ownerElement, const K
     if (ownerElement->hasTagName(frameTag) || ownerElement->hasTagName(iframeTag)) {
         HTMLFrameElementBase* o = static_cast<HTMLFrameElementBase*>(ownerElement);
         allowsScrolling = o->scrollingMode() != ScrollbarAlwaysOff;
-        marginWidth = o->getMarginWidth();
-        marginHeight = o->getMarginHeight();
+        marginWidth = o->marginWidth();
+        marginHeight = o->marginHeight();
     }
 
     if (!ownerElement->document()->securityOrigin()->canDisplay(url)) {
diff --git a/WebCore/page/FrameView.cpp b/WebCore/page/FrameView.cpp
index 8873c53..f2e6e1f 100644
--- a/WebCore/page/FrameView.cpp
+++ b/WebCore/page/FrameView.cpp
@@ -253,8 +253,8 @@ void FrameView::init()
         HTMLFrameElement* frameElt = static_cast<HTMLFrameElement*>(ownerElement);
         if (frameElt->scrollingMode() == ScrollbarAlwaysOff)
             setCanHaveScrollbars(false);
-        int marginWidth = frameElt->getMarginWidth();
-        int marginHeight = frameElt->getMarginHeight();
+        int marginWidth = frameElt->marginWidth();
+        int marginHeight = frameElt->marginHeight();
         if (marginWidth != -1)
             setMarginWidth(marginWidth);
         if (marginHeight != -1)
diff --git a/WebCore/rendering/RenderEmbeddedObject.cpp b/WebCore/rendering/RenderEmbeddedObject.cpp
index 294ffec..fa31ddf 100644
--- a/WebCore/rendering/RenderEmbeddedObject.cpp
+++ b/WebCore/rendering/RenderEmbeddedObject.cpp
@@ -234,17 +234,17 @@ void RenderEmbeddedObject::viewCleared()
     // This is required for <object> elements whose contents are rendered by WebCore (e.g. src="foo.html").
     if (node() && widget() && widget()->isFrameView()) {
         FrameView* view = static_cast<FrameView*>(widget());
-        int marginw = -1;
-        int marginh = -1;
+        int marginWidth = -1;
+        int marginHeight = -1;
         if (node()->hasTagName(iframeTag)) {
             HTMLIFrameElement* frame = static_cast<HTMLIFrameElement*>(node());
-            marginw = frame->getMarginWidth();
-            marginh = frame->getMarginHeight();
+            marginWidth = frame->marginWidth();
+            marginHeight = frame->marginHeight();
         }
-        if (marginw != -1)
-            view->setMarginWidth(marginw);
-        if (marginh != -1)
-            view->setMarginHeight(marginh);
+        if (marginWidth != -1)
+            view->setMarginWidth(marginWidth);
+        if (marginHeight != -1)
+            view->setMarginHeight(marginHeight);
     }
 }
  
diff --git a/WebCore/rendering/RenderFrame.cpp b/WebCore/rendering/RenderFrame.cpp
index b05ea39..a2ebda1 100644
--- a/WebCore/rendering/RenderFrame.cpp
+++ b/WebCore/rendering/RenderFrame.cpp
@@ -50,13 +50,13 @@ void RenderFrame::viewCleared()
 
     FrameView* view = static_cast<FrameView*>(widget());
 
-    int marginw = element->getMarginWidth();
-    int marginh = element->getMarginHeight();
+    int marginWidth = element->marginWidth();
+    int marginHeight = element->marginHeight();
 
-    if (marginw != -1)
-        view->setMarginWidth(marginw);
-    if (marginh != -1)
-        view->setMarginHeight(marginh);
+    if (marginWidth != -1)
+        view->setMarginWidth(marginWidth);
+    if (marginHeight != -1)
+        view->setMarginHeight(marginHeight);
 }
 
 } // namespace WebCore

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list