[Pkg-wmaker-commits] [wmbubble] annotated tag 1.49rc1 created (now d280ea9)

Doug Torrance dtorrance-guest at moszumanska.debian.org
Mon Aug 24 04:18:57 UTC 2015


This is an automated email from the git hooks/post-receive script.

dtorrance-guest pushed a change to annotated tag 1.49rc1
in repository wmbubble.

        at  d280ea9   (tag)
   tagging  22c575e4ad1682907a9458dd4834c04fcdcf2cd1 (commit)
 tagged by  Robert Jacobs
        on  Wed Jan 4 20:04:37 2012 -0800

- Log -----------------------------------------------------------------
Tell git to call the current state 1.49rc1

Jari Aalto (25):
      debian/changelog: Fix Debian distribution target tag
      debian/control: (Description): Delete multiple spaces
      control: (Depends): Add missing ${misc:Depends}
      rules: (install): Use dh_prep
      control: (Standards-Version): Update to latest 3.9.2
      control: (Build-Depends): Update to latest debhelper 8
      compat: update to latest 8
      debian/source/format: new
      control: (Build-Depends): remove obsolte dpatch
      rules: Remove dpatch
      rules: Update to latest dh(1) format
      debian/changelog: Add missing Debian revision number
      debian/changelog: Delete Extra Emacs variables (keep file clean for any editor)
      debian/changelog: Add missing dot
      clean: New file. Remove binary.
      copyright: Update to DEP5 format
      control: (Description): Remove article (Lintian fix)
      control: (Depends): Fix typo
      control: (Homepage): Add
      manpages: New file
      manpages: Use *.1x
      changelog: Remove EOL whitespace
      rules: Add missing newline
      wmbubble.1x: Fix hyphens
      debian/changelog: Close #632876

Robert Jacobs (111):
      Initial checkin from upstream (asked; he doesn't have anything older)
      Adds support for parsing memory on machines newer than 2.4 (from debian)
      Click to unlock, not leave and enter again (debian)
      Fix build w/ gcc3 (debian)
      Enable duck flipping (and kde_dockapp???) by default (debian)
      Binary can now be renamed and use different Xresources to not conflict with gnome bubblemon (debian)
      Don't run play twice. (why?) (debian)
      Allow CFLAGS to be overridden (debian)
      Fix off-by-one error that caused a segfault when duck was upside-down. (debian)
      Add alpha-blended time and date (supporting Hacker Standard Time)
      Slow render rate to 10Hz (from 67Hz)
      Fix Hacker Standard Time calculation
      Half-merge in TAIL from my maintained version. Massive changes: remove
      futz around with whitespace  (but in two commits to keep diff from confusing lines)
      (other half of whitespace futzing)
      Get all this into VC at ALL
      Tear out old xresources code:
      Remove all the conditional compilation, it's the worst kind of premature optimization.
      Fix stupid oversight segfault
      Enhance profiling ability
      Force-inline (using macros) wmPutPixel for performance (~550fps->600fps)
      Remove detritus from changing bm.samples during runtime
      Finish reformatting all the whitespace, I'd already done enough damage I
      Remove some more pointless/unused code
      Fix FPS displaying mode. Also rename duck_set to draw_duck (more obvious, right?)
      Make duck colors customizable
      Finish getting rid of the stupid macros for draw_duck.
      Make FPS configurable.
      Fix pale, explicit graph digit color controls, and other
      Make magic numbers marginally less magic.
      We're doing bitwise tests, so it's got to be & instead of ==
      Clean up silly warning.
      Fix bursty updates on graphs. Kill ROLLVALUE define (But we should
      Swap graphs so they match the numbers. Remove more stupid macros
      Fix the numbers on the graphs (the underlying image conflicted since
      Finish neutering the insanity in the makefile.
      Kill the awful ratelimiting coroutines on system_memory() -- it adds extra complexity for no merit.
      Remove support for reading memory stats on linux 2.4; add support for 3.0
      Tidy up sys_linux.c:system_memory, since the routines are consistent now.
      fix whitespace in sys_linux.c
      Fix segfault if you never xrdb'd
      Add less stupid API for doing the colorspace conversion (wmbubble's native rgb24 to native XImage)
      Make profiling mechanism a little more versatile, also include measurements of hotspots.
      Start breaking bubblemon_update into major functional parts. Also make
      Add some explicit casts to get rid of warnings.
      Fix stupid mistake on border color.
      There's really no reason to have an ugly in-display FPS meter, remove it.
      GCC seems to make significantly more efficient code when walking
      Wait, I thought I killed USER_CFLAGS! Finish the job. (also, whitespace)
      remove rounding error on profiling FPS calculation
      Split out colorspace conversion from main water-sloshing simulation for profiling purposes
      Remove static from all over bubblemon.c, it breaks profiling on -O3
      1- deprecate pregenerated graph screens, generate them
      use memcpy in draw_digit; gcc knows what to do with it (but doesn't with a normal copying loop?)
      draw_cpudigit: use memcpy which gcc understands better again.
      Catch invalid colors
      Optimize hot spot in loop
      Update profiling numbers.
      Apparently opening /proc/stat is very expensive on linux, and we just
      Tweak the border-drawing code a little bit so that the TR and BL corners are the same
      Break realtime_alpha_blend_of_cpu_usage into 4 separate subsections
      clean up alpha_cpu and alpha_graph and make more similar
      Actually, let's make an invalid xresource parse table fail hard.
      Support localization of the strings for date, although only for ascii characters
      Decouple things that shouldn't be
      No reason to have an array for graph digit colors, we don't use them directly anymore anyway.
      Rename iterators in draw_history to de-obfuscate
      kill stupid draw_pixel routine. Support customizing colors of graph contents
      tidy and fix makefile (-m 755 is redundant; no longer depend on gimp .c dumps)
      draw_duck: make variable names not cryptically short
      Synchronize graph data roll with graph redraw to guarantee smoothness
      Figured out what they were doing to bubblemon_update to deallocate
      fix typo
      Fix thing that looks suspiciously like an error in the fixed-point
      Scale alpha blending transition rates to FPS
      Deprecate extra 'showmem / show_gauge' boolean, just directly use alpha for graph instead.
      Replace "blend" and "memblend" with less-cryptic gauge_alpha and graph_alpha
      remove unused prototypes
      fix const in XrmExtras. Move comment for -m to the right line.
      Make date font fully proportional, although ASCII-only. Make the detection of non-ASCII locales robust.
      Remove all the no-longer-loved files.
      fix -m and -k optins to actually work
      Fix cpu squandering if picture_lock at fully opaque graph.
      Add analog clock (completely reimplemented from wmfishtime, but same idea)
      Don't bother to special-case bm.ripples == 0
      We are not doing ourselves any favors with more named intermediates; remove them.
      Split bubblemon_update into watertank sim and drawing routine
      Accursed integer overflow
      Get rid of this makefile hackery to have two different names. It's just "wmbubble" henceforth.
      Slightly revise descriptions of color parameters
      Prefer integer math as much as possible for calculating clock angles
      Don't bother to test if we should draw the bubble above the water -- we already made sure it was valid before.
      Make drawing bubbles clearer (less pointer walking)
      Allow disabling of various clocks so-as-to override xresources from the commandline
      Fix stupid shifttime bug (advancing 1 hour per refresh)
      The best way to make sure that two arrays stay in sync is to make them the same array.
      Allow the datefont_xpm to usefully be able to become wider than 5 eventually
      Finalize name change(i hope). Make help display more useful. Fix exec-on-left-click.
      Get rid of the Makefile.*; try to make plain Makefile smart enough. Don't have a machine to test on, though...
      More renaming effort. Tried to get rid of the bubblemon name in any outward-facing manner. Still need to revise man page.
      Restore defaults to original upstream values (appropriate for 67Hz redraw rate)
      Updated man page, ?fixed? debian/rules
      Whitespace futzing, hopefully the last time
      Don't bother to dynamically allocate things where the size is fixed at compile time
      Other than the debian/ directory, I think we're good to release 1.50; release as 1.49rc1
      Merge branch 'wmbubble.1x' of https://github.com/jaalto/wmbubble
      Rename .1x manpage to .1
      Switch to preferred email address
      Wakwak script should be executable. Maybe we should suggest sox
      Removed debian/ to make distribution outside of debian clean
      Fix bundled documentation; nothing is configurable at build time anymore

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-wmaker/wmbubble.git



More information about the Pkg-wmaker-commits mailing list