Bug#376963: [Pkg-xfce-devel] Bug#376963: xfce4-session: logout button doesn't work

Yves-Alexis Perez corsac at corsac.net
Fri Jul 7 06:35:38 UTC 2006

On Fri, 2006-07-07 at 00:23 +0200, Hein Zelle wrote:
> Yves-Alexis Perez wrote:
> > Just to be sure, are you using official debian packages from unstable ?
> > Similar problem has been reported when using non-official packages we
> > made available at xfce.corsac.net (i386), so maybe it's your case.
> Yes, I'm using the official packages from debian unstable.
> > Why not using the xfce4 xinitrc ? It'll configure the environnement,
> > etc.. Maybe something is missing. I don't know how xdm handles startup
> > script, but try to make it use "startxfce".
> I thought xfce4-session was the recommended way (and read below, it
> works fine again) so I hadn't tried startxfce.

startxfce4 runs xfce4-session if it was found on the system, and runs a
default environnment either.

> I've tried it and it didn't solve the problem directly, but it DID
> lead me to the solution:
> The program iceauth lives in /usr/bin/X11 on my system these days,
> just like several other programs on my system that appeared to be
> "lost".  After I switched to startxfce4, I noticed in my
> xsession-errors that it couldn't find the iceauth program.  I made a
> link to /usr/bin/iceauth, and all is well again.

on my system (debian unstable):

corsac at hidalgo: which iceauth                                        [~]

Maybe you missed an Xorg transition or something ? iceauth is in
xbase-clients it may have moved from a path to another.

> I don't know what caused the move to /usr/bin/X11 (policy change?),
> nor what is the right solution.  I'm sure it's not symlinks in
> /usr/bin ... Should I add /usr/bin/X11 to the system path somewhere?

I guess it's Xorg 6.9 to 7 transition. Try to see here:
> > If you need to tune it, you can copy /etc/xdg/xfce4/xinitrc to
> > ~/.xinitrc and edit it by hand.
> I've reverted to using xfce4-session, as it appears to work just as
> well and doesn't try to start X at the beginning (since it is already
> running).  startxfce4 does try to do that, it seems.

Yes, startxfce4 runs X if not running, and then set up the
environnement, then tries to run xfce4-session if available.
> > And if you need to run some programs when entering desktop, there is an
> > "Autostarted applications" available (menu, settings, autostarted
> > applications) for your convenience (and session management should
> > provide similar feature).
> I can't find that program in the menu: I only get the "settings
> manager" under the "settings" menu.  I don't see any options for
> autostarting applications in the settings manager either.

It's not in the settings manager in 4.4B1 (should be in 4.4B2 iirc). But
you should have a list of configurable settings under the Settings item
in the xfdesktop menu. You can also run xfce4-autostart-editor

> Thanks for your tips and help in solving the problem.  Should I report
> the bug as fixed to someone, or will you do that?

Let's be sure there is no bug, then we'll take care of that :)

Yves-Alexis Perez

More information about the Pkg-xfce-devel mailing list